Excel - Problemas Funcion Excel

   
Vista:

Problemas Funcion Excel

Publicado por FernandoML (19 intervenciones) el 19/10/2007 12:01:23
Hola a todos como estais tengo un problema que espero me podais ayudar.

Mi problema es el siguiente.

en la celda A1 Inserto la fecha actual.
A1=FECHA(HOY())

En la celda A2 le digo que me ponga el dia de la semana a la que pertece la celda A1
A2=DIASEM(A1)
Lo que me da un numero del 1 al 7

Lo que quiero hacer es lo siguiente:
En la celda A3 tengo escrito por ejemplo la letra M y lo que quiero es que si la celda
A2=7 o A2=1 entonces que me concatene el contenido de la celda A3 con porejemplo
un punto quedando "M." dentro de la celda A3.

Esto lo quiero hacer dentro de un formato condicional el cual no me lo hace
sabeis alguna manera para poder acerlo?

Gracias a todos por vuestro tiempo y espero que alguien me pueda ayudar.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas Funcion Excel

Publicado por Guillermo (19 intervenciones) el 19/10/2007 15:15:04
Hola Fernando.

Primero, para poner la fecha de hoy debes poner solamente =hoy() en A1

Si quieres utilizar la función FECHA, la sintaxis es distinta =FECHA(año;mes;día)

Segundo, la función DIASEM, tiene la sintaxis =DIASEM(fecha, código)

Según lo que tu dices, deseas que te devuelva 1 y 7 para domingo y sábado, en este caso el código es 1. Tal vez más fácil es si usas el código 2 que devuelve 1 para lunes, y sábado y domingo devuelven 5 y 6.

Entonces en tercer lugar, si en la función DIASEM usas código 1, para que te ponga "M." debes poner =SI(O(A2=1,A2=7),"M.","")

Si usaras el código 2 en DIASEM, la función en A3 es =SI(a2>5,"M.","")

Si quieres copiar las funciones como yo las escribí, debes tener en cuenta que en mi configuración uso la coma (,) como separador y no el punto y coma (;).

Saludos y espero haberte ayudado (si te sirvió avisa.)

Guillermo
Montevideo, Uruguay
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas Funcion Excel

Publicado por FernandoML (19 intervenciones) el 29/10/2007 10:51:58
Muchas gracias guillermo me ha servido mucho tu contestacion
he podido solucionar mi problema gracias otra vez
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar