Excel - COMPLICADO? Fórmula matricial en macro

   
Vista:

COMPLICADO? Fórmula matricial en macro

Publicado por Oskar (1 intervención) el 17/12/2007 00:20:41
Estoy tratando de insertar una fórmula matricial en una determinada celda de una hoja desde una macro, pero me es imposible. La fórmula que quiero introducir es:

{=SUMA(SI('Compras 2007'!$E$2:$E$65536=FECHANUMERO("1/01/2007");SI('Compras 2007'!$A$2:$A$65536>="191";SI('Compras 2007'!$A$2:$A$65536<="199";'Compras 2007'!$D$2:$D$65536;0);0);0))}

Los rangos están en otra hoja (llamada 'Compras 2007') y así es como se ve la fórmula al ponerme encima de la celda de la hoja de Excel en que está (que no es la hoja de los rangos a que se hace referencia), pero lo que quiero es saber cómo tengo que ponerla al crear una macro (Sub...).

Si alguien puede echar una mano estaría agradecido...
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:COMPLICADO? Fórmula matricial en macro

Publicado por JuanC (792 intervenciones) el 17/12/2007 13:10:03
utiliza FormulaArray

Saludos desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar