Excel - Nombre de hoja como variable...

   
Vista:

Nombre de hoja como variable...

Publicado por coke (1 intervención) el 09/07/2008 21:35:03
Hola amgos que tal , tengo una pequeña duda :

tengo 4 hojas , enero, febrero, marzo y abril con una serie de datos numericos, quiero hacer lo siguiente, en una hoja resultado quiero poder elegir dos de estas 4 hojas y poder restar los resultados de una a otra.

para restar dos casillas en diferentes hojas lo hago de esta manera :

=Enero!B3-Febrero!C3

Pero lo que quiero hacer es que automaticamente me coja el valor de una casilla en la que saldran los meses.... (enero, febrero,marzo....)

No se como decirle a esa formula que el "enero" es una variable que se coje de la casilla d5 por ejemplo.

Gracias¡
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Nombre de hoja como variable...

Publicado por Octavio Illescas (46 intervenciones) el 10/07/2008 01:14:50
Usa esta formula como referencia
=SI(D1="Hoja1",B1-Hoja1!A1,SI(D1="Hoja2",B1-Hoja2!A1,SI(D1="Hoja3",B1-Hoja3!A1,SI(D1="Hoja4",B1-Hoja4!A1,"No existe el rango"))))

Donde D4 es la celda para cambiar valores, B1 es la celda de que la que se va restar y B2 es el resultado
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Nombre de hoja como variable...

Publicado por Santiago (193 intervenciones) el 10/07/2008 05:26:59
Te mando la formula es muy simple:
A1 = Enero
A2 = Febrero
A3 = =INDIRECTO(CONCATENAR(A1,"!B3"))-INDIRECTO(CONCATENAR(A2,"!C3"))

Espero que te sirva

Un saludo
SCM
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Nombre de hoja como variable...

Publicado por ricardo (1 intervención) el 29/08/2008 12:35:16
Muchas gracias. Esa función de INDIRECTO no la conocía pero es una maravilla.

Salu2
ricardo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar