FoxPro/Visual FoxPro - Ayuda!! Cambié de versión y no me anda un listado!

   
Vista:

Ayuda!! Cambié de versión y no me anda un listado!

Publicado por Andrea (325 intervenciones) el 21/01/2009 22:32:02
Hola a todos

Tengo un listado (reporte) que utilizaba en el versión 6.0 de VFP y funciona bien.

Empecé a hacer otro programa pero con la versión 9 de VFP y quiero reutilizar el report que utilizaba en la función 6.0

Después de adaptarlo y hacer algunas reformas, da un error PERO SOLAMENTE cuando habilito (tido en el checkbox) "REMOVE LINE IF BLANK" (que en la versión 6 era "Quitar líneas en blanco")

El error que da es "El valor, tipo o nº de argumento no es válido para la función..."

Lo raro es que si yo deshabilito la casilla funciona perfecto (aunque me repite líneas en blanco, sin nada)

¿QUE PUEDE SER?
Estoy un poco desesperada porque debe ser algo sencillo pero me está demorando todo lo demás.

Muchas gracias!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Ayuda!! Cambié de versión y no me anda un lista

Publicado por Plinio (7771 intervenciones) el 22/01/2009 02:38:40
Tienes que ver lo que tienes en la condicion Print When. Talvez el tipo de datos es distinto a lo que estas preguntando.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Ayuda!! Cambié de versión y no me anda un lista

Publicado por Andrea (325 intervenciones) el 22/01/2009 13:00:33
Gracias Plinio, pero...

- en Print When al habilitar la opción "PRINT ONLY WHEN EXPRESSION IS TRUE", deja las demás opciones deshabilitadas, así que ahí no hay mucho que hacer

En la condicion lógica escribí :
nVariable=1

Por las dudas me aseguré previamente que nVariable sea numérico con la función VARTYPE( ), es decir, devuelve N

¿QUÉ PUEDE SER??
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar