FoxPro/Visual FoxPro - Problema con grid

   
Vista:

Problema con grid

Publicado por Ovelit  (126 intervenciones) el 02/02/2009 15:12:11
saludos foxeros

tengo el siguiente problema

tengo un grid q lo lleno con un cursor, el detalle esta cuando quiero ir a una columna del grid y ejecutar cualquier evento.

por ejemplo tengo el siguiente grid

articulo cantidad precio total
xxx 1 100 100

el problema esta cuando quiero cambiar la cantidad

yo por ejemplo estoy programando el evento lostfocus pero no me hace nada

y la prueba la hago tambien en el evento click colocando un messagebox() para probar pero nada

que estara pasando ahi o es q me falta activar un propiedad del grid
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema con grid

Publicado por ANDRES CORTEZ M (162 intervenciones) el 02/02/2009 18:30:39
HOLA OVELIT

¿ Esta provando en el evento setfocus y click del columns o text1 del columns?

¿ Verifica el columncount del Grid que corresponda a la cantidad de columna ?

¿ Verifica el recordsource debe tener asignado el cursor. ?

¿ Verifica el recordsourceTYPE debe ser 1 - alias ?

espero te sirva

ACM
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con grid

Publicado por Ovelit  (126 intervenciones) el 03/02/2009 15:15:51
saludos andres muchas gracias por tu comentarios.

ya soluciones lo de ejecutar el codigo en el evento xxx de cualquier columna del grid
el problema era que el TYPE DEL RECORDSOURCE LO TENIA =0 tabla y ahora lo coloque como me comentantes y todo bien...

ahora el problema es el siguiente

tengo una caja de texto donde hago una busqueda y depende de la busqueda se deberia llenar el grid

le estoy colocando la recordsource el nombre del cursor que se realiza en esa busqueda pero el grid no se llena osea no coloca los datos q me trae el cuersor

otra cosa cuando el type del recordsource era= 0 TABLA si me llena el grid

que estara pasando ahora.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con grid

Publicado por ANDRES CORTEZ MONTAÑO (162 intervenciones) el 05/02/2009 17:56:50
HOLA OVELIT

Al parecer te falta ejemplo

THISFORM.GRID1.REFRESH

espero te sirva

ACM.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar