FoxPro/Visual FoxPro - ayuda con indices no entiendo

   
Vista:

ayuda con indices no entiendo

Publicado por rossana (5 intervenciones) el 09/03/2009 03:06:35
hola a todos, tengo una base de datos con mas de 70000 registros, inicie con vfp 60 ahora cambie a visual fox 9 y agrege nuevos informes por lo que necesite crear un indice mas, pero me da mensaje de erro cuando en el programa hago append blank, cree de nuevo todos los indices, reindex la base de datos, valide la base, no se que puede ser por favor si me ayudan como siempre
muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ayuda con indices no entiendo

Publicado por jose camilo (688 intervenciones) el 09/03/2009 13:33:40
abre las tablas de manera exclusiva

quitale todos los indeces

cierralas

abrelas otra vez

reasignale todos los indices
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ayuda con indices no entiendo

Publicado por wenceslao Piraquive (134 intervenciones) el 10/03/2009 20:15:37
cheka que las tablas no esten en solo lectura
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ayuda con indices no entiendo

Publicado por Silvio (3 intervenciones) el 11/03/2009 03:29:17
Verifica que no se viole alguna regla de integridad referencial, como duplicación de claves principales, por ejemplo. Es factible que te arroje este error si agregas dos registros en blanco.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar