FoxPro/Visual FoxPro - ayuda por favor

   
Vista:

ayuda por favor

Publicado por mario (90 intervenciones) el 15/04/2009 16:09:09
hola a todos tengo dos problemas que no puedo solucionar si alguien me ayuda por favor
1er problema:
cuando debo borrar algunos datos de una tabla especifica yo programo de esta forma
use cliente exclusive
select cliente
set orden to tag codigocliente
if seek (codigocliente)
delete
pack
endif
use cliente shared

pero cuando le doy borrar me sale un mensaje "debe abrirse en modo exclusivo" ya e intentado de todo y no encuentro el problema.

2do problema:
creo el ejecutable, cuando quiero entrar al sistema desde el ejecutable me sale " error al cargar el archivo nº de registro 4 formulario acceso. cargando el formulario o el entorno de datos, denegado el acceso al archivo.

si alguien me puede ayudar por favor
desde ya muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ayuda por favor

Publicado por Marvin E. Pineda (75 intervenciones) el 15/04/2009 16:27:33
1er problema

asegurate de tener cerradas todas las tablas antes de abrirla en modo exclusivo..

close tables all
use cliente exclusive
*! y demas codigo

y no utilices use cliente shared, solo mejor cierrala y luego abrela normal

use in select("cliente'")
use cliente

2do problema.

alguna tabla se esta abriendo en modo exclusivo cuando cargar que te esta mostrando ese error
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar