FoxPro/Visual FoxPro - rutas en vfp 6

   
Vista:

rutas en vfp 6

Publicado por eduardo (16 intervenciones) el 14/10/2010 19:37:12
Hola gente, queria consultarles un problemita que tengo. Hice un sistema en el que en algunos formularios en vez de mostrar un texto en los botones, muestra una figura mediante la propiedad picture del command. Al hacer clic en dicho boton esa figura cambia por otra. La codificacion que tiene ese boton adentro para que cambie de figura es la siguiente (thisform.command5.picture="d:\inst.sup.jujuy\nueva carpeta\simbolos\wznew.bmp"). Mi problema es el siguiente, cuando yo genero el .exe y los instaladores distribuibles e instalo el sistema en unidad C: por ejemplo, esos botones que cambian de picture no funcionan. Me dijeron que ese tipo de ruta que estoy poniendo en la codificacion no debe ser asi porque estoy obligando al sistema a instalarse en esa ruta para que esos botones cambien de figura sin problemas. Pero entonces como o que ruta debo poner para que esos botones funcionen???, saludos. Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Javier

RE:rutas en vfp 6

Publicado por Javier (22 intervenciones) el 14/10/2010 21:04:09
Hola flakosakeo:
Deja de m.a.r.i.c.o.n.e.a.r. y fijate en tu email.
Javier
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauricio

Rutas en vfp 6

Publicado por Mauricio (1368 intervenciones) el 14/10/2010 23:59:42
Eduardo, no te compliques la vida, es sencillo:
Pon esas figuras en la carpeta donde esta tu sistema, asi ya no tendras esos problemas, solo tienes que copiarlos. Tan dificil te resulta?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Rutas en vfp 6

Publicado por eduardo (16 intervenciones) el 15/10/2010 00:59:11
te agradezco, lo voy a probar. Otra cosita, con los reportes tambien tengo drama, cuando quiero generar uno me sale un cartel que dice "index tag is not found" y se cierra el sistema, que puede ser???, gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauricio

Rutas en vfp 6

Publicado por Mauricio (1368 intervenciones) el 15/10/2010 02:09:59
pueden ser 2 de muchas cosas:
1 Que en el ambiente del reporte tienes abierta una tabla con un indice que no existe.
2 Que cuando estabas desarrollando el reporte, por cualquier motivo ya sea por usar vista previa y no tener abierta ninguna tabla la abriste o ya tenias abierta una tabla con un indice que luego posiblemente borraste....
Suerte!!!!!!!!!!!!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:rutas en vfp 6

Publicado por Juanma Cruz (508 intervenciones) el 15/10/2010 12:45:27
No uses rutas absolutas, simplemente el nombre de archivo de la imagen.

Asegúrate que ambos BMPs están incluidos dentro del Administrador del Proyecto. El que has puesto en la propiedad PICTURE en el diseñador estará incluido desde el primer BUILD que realices. El segundo BMP que mencionas por código al hacer click, debes incluirlo a mano en el proyecto.

De esta manera, cuando se genera el EXE, éste tendrá dentro los BMPs.

Fox resuelve de esta manera:

Si indicas un recurso, primero lo busca dentro del EXE. Si ahí no está (y estará, si sigues esta indicación que te doy) lo busca en la carpeta del ejecutable, la ruta por defecto, el PATH, la carpeta del sistema operativo... etc. En ese orden.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:rutas en vfp 6

Publicado por eduardo (16 intervenciones) el 15/10/2010 19:43:08
ok, gracias juanma. Podrias leer la nota anterior que yo escribi del dia 15/10, es la primer nota de ese dia, se trata de un problema que tengo con los reportes. Gracias juanma te agradezco.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:rutas en vfp 6

Publicado por Juanma Cruz (508 intervenciones) el 18/10/2010 10:18:31
La respuesta que te dió Mauricio es la misma que yo te daría. Revisa que no has dejado referencia a una tabla temporal indexada, o que tu DataEnvironment es correcto.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar