GeneXus - Exportación a Excel con formulas

   
Vista:

Exportación a Excel con formulas

Publicado por Erik (28 intervenciones) el 15/12/2008 20:00:32
Hola que tal, me pregunto si hay alguna forma de hacer una exportación a excel con el tipo de datos ExcelDocument y poder utilizar formulas para que las reconozca Excel al abrir el documento; intenté algo asi:
&VAREXCEL.Cells(&ren,&col).Text = "=SUMA(A1:A10)"
para que en teoria se escriba la formula en la celda donde deseo el resultado (esto lo he hecho en otro lenguajes de programación y ha funcionado); pero al generar el archivo exportado me marca error en la formula y lo reconoce como texto inválido en formula; pero al posicionarme dentro de la celda y presionar Enter me reconoce la formula y muestra el resultado correctamente; pero hacer esto es muy impractico ya que son demasiadas formulas; alguien sabe de alguna forma para que se reconozcan las formulas?

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Exportación a Excel con formulas

Publicado por Richard (1 intervención) el 13/03/2009 16:55:24
Erik, proba con comillas simples como si fuera un texto.

&VAREXCEL.Cells(&ren,&col).Text = '=SUMA(A1:A10)'
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar