GeneXus - Problema al generar Main de mENU

   
Vista:

Problema al generar Main de mENU

Publicado por jaed (36 intervenciones) el 06/02/2008 14:23:52
Hola compañeros
Tengo el siguiente problema. Al generar como Main un objeto menú siempre me da un error del tipo:
Could not find file "C:Documents and SettingsNewKB5DATA002ldlMnu01.cs".

Con el resto de objetos como transacciones funciona perfectamente.

Genexus 9 generador .NET y Postgresql

saludos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema al generar Main de mENU

Publicado por Patricio Ojeda V (1 intervención) el 11/02/2008 00:16:35
Jaed,

Seguramente al compilar tu Menu, dentro del arbol de llamadas de este se debe hacer referencia a este objeto, y como genexus no lo encuentra te manda ese error.

Lo que podrias hacer es hacer un Build All, y forzar nuevamente la generacion y compilacion de todos los objetos de tu modelo.

saludos

Patricio Ojeda V
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema al generar Main de mENU

Publicado por jaed (36 intervenciones) el 12/02/2008 08:24:20
Hola Patricio.

Salvo error he hecho lo que me indicabas y sigue sin funcionar,es decir:

1º)He hecho build all
2º)He compilado y ejecutado el menu al que he puesto la propiedad `como main.

Me sigue dando el error: No se puede encontrar bldMnu01.cs

En cualquier caso no entiendo la frase: Seguramente al compilar tu Menu, dentro del arbol de llamadas de este se debe hacer referencia a este objeto.
Seguramente hay algo que no hago bien.Si puedes te agradeceré me amplies un poco más la información.

saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema al generar Main de mENU

Publicado por luis (82 intervenciones) el 12/02/2008 12:16:34
Creo que si tu tiene por ejemplo. el menu01 que es un exe, y dentro de ese llamas al menu02 que tambien es un exe, debes generar y compilar ambos menu, para que te funcione bien. Creo que eso te quiso decir Patricio. Saludos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema al generar Main de mENU

Publicado por jaed (36 intervenciones) el 12/02/2008 13:13:38
Hola Luis
El problema es anterior ya que no me permite generar el exe del menu01.Al hacer el buil all no pasa nada, pero al compilar el main menu01 es cuando me da el error.

saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Patricio Ojeda V

RE:Problema al generar Main de mENU

Publicado por Patricio Ojeda V (454 intervenciones) el 12/02/2008 14:30:46
Para que no pierdas mas tiempo y no sigas haciendo Build All los cuales no te han llevado a nada, lo que podrias hacer es crearte otro Modelo desde cero e impactar los objetos desde tu modelo antiguo al modelo nuevo. Luego de esto haces Build All y pruebas.

Como ultima opcion podrias crear una nueva KB, distribuir y consolidar los objetos, y crearte en esta nueva KB un modelo completamente nuevecito desde cero.

Por otra parte fijate si tienes todo lo que se debe para trabajar en .Net, o sea..

Framework 1.1 y J# 1.1 o Framework 2.0 y J# 2.0

Saludos

Patricio Ojeda V
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema al generar Main de mENU

Publicado por jaed (36 intervenciones) el 12/02/2008 15:50:02
Hola Patricio

Pienso que algo se me escapa. Te voy a explicar lo que he hecho.

1º) He generado una nueva KB
2º) He añadido dos transacciones
3º) He añadido un menu. He dado dos veces a Add, asignando como programa a cada una de las veces una de las transacciones.He dejado el resto por defecto, he cambiado las propiedades del menú a Main, dejando el resto sin más.

No funciona y da el error de que no encuentra el bldMnu01.cs

El resto de las compilaciones funcionan bien por lo tanto pienso que todo lo instalado, tanto el Framework 2.0 como el J# 2.0 están bien.

saludos y gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar