GeneXus - No ejecuta la transaccion

   
Vista:

No ejecuta la transaccion

Publicado por Rodrigo (9 intervenciones) el 05/06/2008 16:50:07
Tengo problemas para ejecutar la transaccion, hice una de prueba con tres atributos uno de tipo numerico,otro de tipo fecha, y otro de tipo char. Logro compilar bien la transacción, ejecuto el developermenu y lo ejecuta cuando ejecuto la transacción lo hace pero despues no me deja hacer nada dice terminado abajo en el navegar y no hace nada, lo unico que hace es cuando quiero cargar una fecha invalida me dice que la fecha no es valida pero no carga nada en la base de batos y tampoco me muestra las cosas que tiene la base de datos, le cargue unos valores a mano y nada....

Ayuda por favor....
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:No ejecuta la transaccion

Publicado por luis (82 intervenciones) el 05/06/2008 22:14:59
Hola, proba hacer un work panel de seleccion previo, que sea main program, y pasale parametros a la trn en el modo que la quieras ejecutar. Por ejemplo, en el work panel en el boton agregar ponele Call(TTrn, 'INS'), y en la trn pone Parm(&Mode); en rulez. Capaz que asi te funcione. Saludos. Luis.-
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No ejecuta la transaccion

Publicado por Rodrigo (9 intervenciones) el 06/06/2008 14:26:31
Muchas gracias por contestar... Probe lo que me dijiste y nada. Yo ya habia intentado hacer algo parecido con un reporte pero no me ejecuta los eventos propios de genexus. Si ejecuto a mano el web panel que te crea solo me andan las busquedas, pero si ejecuto la transaccion no me hace nada solo me valida la fecha si coloco una fecha incorrecta... Puede ser un problema de classes.... Me espara faltando colocarle alguna clase?????

Muchas gracias de nuevo.....
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Patricio Ojeda V

RE:No ejecuta la transaccion

Publicado por Patricio Ojeda V (454 intervenciones) el 06/06/2008 16:33:13
Rodrigo,

Para que los foristas te puedan ayudar... debes partir contando con que Lenguaje, Dbms y version de Genexus estas trabajando.

Ademas deberias contarnos las configuraciones basicas de tu modelo...

Saludos

Patricio Ojeda V
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No ejecuta la transaccion

Publicado por rodrigo (9 intervenciones) el 06/06/2008 22:50:20
Estoy trabajando con genexus 9.0 con la ultima actualización, quiero compila en java-web y el dbms es sql server 2005.

Tenia problemas para que me ejecute los botones de la transacción, después de tocar algo que no se que.... empezó a andar bien ahora cuando agrego algo a la transacción ya sea un botón o un texto puro no me lo muestra en ejecución.....

Que puede ser....

Muchas gracias a todos...

Rodrigo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar