Linux - Ayuda con build-essential

   
Vista:
Imágen de perfil de Dan

Ayuda con build-essential

Publicado por Dan (218 intervenciones) el 16/03/2014 20:54:19
Me baje el build-essential pero no trae ningun headerfile (.h) por ninguna parte.
Donde estan????
MUchas GRACIAS
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Linux
- Cursos de Linux
- Temas de Linux
- Chat de Linux
información
Cursos y Temas de Linux
- Introducción a FreeBSD
- Curso de Linux v2.0
- Introducción a ProFTPD
Imágen de perfil de xve

Ayuda con build-essential

Publicado por xve (664 intervenciones) el 17/03/2014 07:44:57
Hola Dan, la verdad es que todavía no sabemos que quieres hacer... por lo que no se que archivos estas buscando!!

Informational list of build-essential packages
If you do not plan to build Debian packages, you don't need this
package. Starting with dpkg (>= 1.14.18) this package is required
for building Debian packages.
.
This package contains an informational list of packages which are
considered essential for building Debian packages. This package also
depends on the packages on that list, to make it easy to have the
build-essential packages installed.
.
If you have this package installed, you only need to install whatever
a package specifies as its build-time dependencies to build the
package. Conversely, if you are determining what your package needs
to build-depend on, you can always leave out the packages this
package depends on.
.
This package is NOT the definition of what packages are
build-essential; the real definition is in the Debian Policy Manual.
This package contains merely an informational list, which is all
most people need. However, if this package and the manual disagree,
the manual is correct.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Dan

Ayuda con build-essential

Publicado por Dan (218 intervenciones) el 17/03/2014 14:49:17
Veras necesito archivos .h de C que si aparte de para
lo que los quiero yo tambien sirven para compilar
software en .tar.gz
http://amayaos.wordpress.com/acerca-de/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de barna_rasta

Ayuda con build-essential

Publicado por barna_rasta (146 intervenciones) el 17/03/2014 16:28:55
Hola Dan,
leo de amayaOS,
1
Amaya OS – Es un sistema operativo de tipo UNIX con Kernel FNX 0.05-alpha1 y ademas esta considerado una variante del sistema operativo GNU ya que incluye software de dicho sistema operativo.
por lo que pienso que los headers de debian quizas no sirvan para compilar bajo amaya, pero me hace dudar despues de encontrar informacion que referencia librerias Debian.

Tambien te encontre esto:

http://www.w3.org/Amaya/User/AmayaWX.html

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
What do I need to compile this version ?
 
Once you got the run needed librairies, you'll need the developpement package that containts headers and static libraries:
Required libraries

Debian Stable
    libfreetype6-dev
    libxt-dev
    libgtk2.0-dev
    xlibmesa-gl
    xlibmesa-glu
    xlibmesa-glu-dev
    libglu1-mesa
    xlibmesa-gl-dev or xlibmesa-dev
    libtool
    libraptor1-dev
    libssl-dev


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
How to compile Amaya-WX
On Unix platforms
 
    Download full unix sources of Amaya :
 
    amaya-sources-xxx.tgz
    Untar sources :
 
    tar xzvf amaya-sources-xxx.tgz
    Configure and compile Amaya :
 
    cd Amaya
    mkdir WX
    cd WX
    ../configure
    make
    Installing Amaya :
 
    su
    make install
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Dan

Ayuda con build-essential

Publicado por Dan (218 intervenciones) el 17/03/2014 20:10:50
Pero donde puedo conseguir los headers file?? (.h)
y con amaya os me refiero al sistema opertivo que estoy
dessarrollando y me gustaria que tuviera mas software
que ls y cat por eso necesito los headers
¿donde puedo conseguirlos?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de barna_rasta

Ayuda con build-essential

Publicado por barna_rasta (146 intervenciones) el 18/03/2014 00:13:10
Pues amigo Dan,
la verdad es que el tema es un tanto confuso, pero si el tal AMAYA OS es que el que referencie anteriormente y esta basado en Debian ya que parece que utiliza sus propias librerias, podrias mirar de instalar el headers - para realizar compilaciones posteriores -, de la siguiente forma:

**** suponiendo que incorpora el command " uname " y reconoce "aptitude"
# aptitude install linux-headers-$(uname -r)

*** de lo contrario deberas averiguar la version y sustituir "$(uname -r)" , quedando algo asi :

# aptitude install linux-headers-2.6-686

The Amaya binary distribution is available for PC Linux, Windows and Mac OS X. Users having other architectures are expected to compile the Amaya http://www.w3.org/Amaya/User/SourceDist.html.
http://www.w3.org/Amaya/User/BinDist.html



http://www.w3.org/Amaya/Distribution/amaya_11.4.4-1_i386.deb
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Dan

Ayuda con build-essential

Publicado por Dan (218 intervenciones) el 18/03/2014 14:56:50
Cambiemos de pregunta.
Como hago para compilar python , nano , coreutils????
Si no tengo todos los header files (.h) necesarios???
GRACIAS
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de barna_rasta

Ayuda con build-essential

Publicado por barna_rasta (146 intervenciones) el 18/03/2014 20:04:08
Pues teniendo ya instalado el compilador solo tienes que conseguirte el codigo fuente
descomprimir
compilar.

Para nano:
1
2
3
4
5
6
7
# wget http://www.nano-editor.org/dist/v2.0/nano-2.0.6.tar.gz
# tar -zxvf nano-2.0.6.tar.gz
# cd nano-2.0.6
# ./configure
# make
# make install
# reboot
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar