Linux - Centos 6.5 problemas al instalar php_gd

   
Vista:

Centos 6.5 problemas al instalar php_gd

Publicado por Naiki (2 intervenciones) el 01/01/2015 15:26:28
Hola a todos!!

Soy nuevo en este foro, quisiera agradeceros de antemano vuestra ayuda, y también tengo que decir que soy un principiante en todo lo relacionado a Linux.

Llevo unas cuantas horas intentando instalar php_gd en el servidor, pero me dice que php55w-common esta en conflicto con php-common-5.3.3-40.el6_6.x86_64. No se por donde agarrarlo, y agradecería cualquier indicación.

Tengo el Centos 6.5 x64 en el servidor y PHP Version 5.5.18 instalado.

Ejecuto el comando "sudo yum install php-gd" y me da el siguiente error:
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.datente.com
* extras: ftp.plusline.de
* rpmforge: mirror.de.leaseweb.net
* updates: mirror.softaculous.com
* webtatic: uk.repo.webtatic.com
base | 3.7 kB 00:00
extras | 3.4 kB 00:00
rpmforge | 1.9 kB 00:00
updates | 3.4 kB 00:00
webtatic | 3.6 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-gd.x86_64 0:5.3.3-40.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-gd-5.3.3-40.el6_6.x86_64
--> Running transaction check
---> Package php-common.x86_64 0:5.3.3-40.el6_6 will be installed
--> Processing Conflict: php55w-common-5.5.18-1.w6.x86_64 conflicts php-common < 5.5.0
--> Finished Dependency Resolution
Error: php55w-common conflicts with php-common-5.3.3-40.el6_6.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Muchas gracias por vuestro tiempo.

Feliz año nuevo!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Centos 6.5 problemas al instalar php_gd

Publicado por xve (664 intervenciones) el 01/01/2015 19:33:34
Hola Naiki, eso es porque tienes instalada la versión 5.5 del PHP, y el paquete que estas intentando instalar es de la versión 5.3.

Prueba a buscar el paquete de la versión 5.5...
1
yum list available | grep "\-gd"
Seguramente te aparecerá un archivo algo como: php55-gd el cual es el que corresponde con tu versión de php instalado.

Coméntanos, ok?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Centos 6.5 problemas al instalar php_gd

Publicado por Naiki (2 intervenciones) el 01/01/2015 20:37:36
Efectivamente, al final instale php55w-gd.

Muchas gracias!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar