OpenOffice - Ayuda con fórmula compleja en Calc

   
Vista:

Ayuda con fórmula compleja en Calc

Publicado por indigente (1 intervención) el 15/12/2008 10:44:56
Necesito que en una celda se obtenga un dato a partir del valor que introduzco en otra celda. Las fórmulas no son complejas, pero mi problema es que son fórmulas diferentes aplicadas a diferentes rangos en los que pueda estar el valor inicial. Os pongo la forma de calcular:

Desde Hasta Resultado
0 300 1,10
301 3.000 2,45+0,024%
3.001 35.000 4,65+0,012%
35.001 70.000 6,40+0,007%
70.001 140.000 9,20+0,003%
140.001 en adelante 13,40

Las fórmulas en sí no son complejas, lo que no sé hacer es dado el valor inicial, clasificarlo en un rango y aplicar el resultado correspondiente.

¿Alguna idea de cómo hacerlo? ¿Algún ejemplo donde pueda ver cómo se hace?

Gracias mil.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de OpenOffice
- Cursos de OpenOffice
- Temas de OpenOffice
información
Cursos y Temas de OpenOffice
- OpenOffice.org User Guide 1.1
- Manual de OpenOffice Impress
- Curso de OpenOffice Calc 3

RE:Ayuda con fórmula compleja en Calc

Publicado por Jorge (6 intervenciones) el 26/01/2009 07:19:23
Creo que la fórmula sería algo así, con condicionales:
=SI()=SI(A1<=300,1.1,SI(A1<=3000,2.24+0.00024*A1,SI(A1<=35000,4.65+0.00012*A1,SI(A1<=70000,6.4+0.00007*A1,SI(A1<=140000,9.2+0.00003*A1,13.4)))))
NO la cheque bien si es que da lo que quieres, pero esa es la ideas.

Si la tabla fuera más grande, se pueden usar otros comandos.
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar