OpenOffice - Fórmula SumarSi

   
Vista:

Fórmula SumarSi

Publicado por Mikel (2 intervenciones) el 29/09/2009 14:52:18
Buenas tardes,

para sumar todas las horas que tengo planificadas en un mes utilizo lo siguiente:

= SUMAR.SI($Parciales.Z4:Z237;B2;$Parciales.Y4:Y262)

B2 es por ejemplo 1 el cual lo asocio a Enero.
En la columna Z tengo número desde 1 hasta 12 (meses)
En la columna Y tengo el número de horas

lo que quiero es que me sume según mes y AÑO. Es decir, lo anterior me suma todo lo que tengo 1 (Enero) pero no respeta el año.

¿Como puedo introducir que me respete el Año en la fórmula anterior?

Muchas gracias y un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Fórmula SumarSi

Publicado por Eduardo Moreno (4 intervenciones) el 09/12/2009 15:07:52
¿Que tienes en la columna B?
Si son solo números 1,2,3,...,11,12 para los meses, pues el equipo nunca tendrá un a referencia para el año.
Si tienes fechas, podemos intentar algunas cosas.
Primero, necesitas una nueva columna que te sume el año más el mes.
Espero poder explicarme.
Columna A = Fecha
Columna B = Cantidades
Columna C =año(a)*100+mes(a)
Columna D = sumar.si(Cx:Cy;200901;Bx:By)

Al muntiplicar el año por 100 y sumarle el mes tendrás la fecha en formato AAAAMM. Si nquieres las fechas de enero del 2008, pues es 200801.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar