Oracle - No consigo configurar Webutil en Forms 11g, aunque en Forms 10g si lo consegui

   
Vista:

No consigo configurar Webutil en Forms 11g, aunque en Forms 10g si lo consegui

Publicado por Cesar Garcia Vidaur (4 intervenciones) el 11/03/2013 13:42:04
Hace un tiempo instalé Forms 10g sin problemas, a continuación configuré la Webutil y está funcionando, pero ahora han instalado Weblogic Server 11gR1, Forms 11g, Win32_11gR2_database y no he sido capaz en 3 días de configurar la librería webutil para que funcione.

¿alguién tiene funcionando la webutil para que me ayude?, muchas gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

No consigo configurar Webutil en Forms 11g, aunque en Forms 10g si lo consegui

Publicado por luis (232 intervenciones) el 14/03/2013 16:49:38
Hola, te recomiendo revisar el orden de instalación de estos productos oracle ya que al instalarlos reemplazan algunos archivos y librerias de productos anteriores, debes validar cual es el orden de instalación que debes hacer para que el WEBUTIL funcione correctamente.
En mi trabajo anterior cuando necesitabamos instalar nuevos productos teniamos qye validar cual es el orden de instalación para que no existan problemas. Así que si el error que se te presenta es luego de instalar nuevos productos es por que se actualizan los archivos anteriores y luego no funcionan bien las librerías anteriores.

Recomendación de cajón: Antes de instalar cualquier nuevo software validar que este no altere o malogre software anteriores, hacer esta validación en un ambiente de prueba y nunca en un ambiente de producción.

Saludos

Luis
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No consigo configurar Webutil en Forms 11g, aunque en Forms 10g si lo consegui

Publicado por luis (232 intervenciones) el 14/03/2013 16:56:43
Aquí unas recomendaciones del FORO oracle :

https://forums.oracle.com/forums/thread.jspa?threadID=2344639
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No consigo configurar Webutil en Forms 11g, aunque en Forms 10g si lo consegui

Publicado por Cesar1956 cesargv1956@hotmail.com (4 intervenciones) el 18/03/2013 13:23:29
todo lo que encuentro a cerca de configurar Webutil es para Forms 10g.

He instalado en mi ordenador :

wls1036_win32.exe
win32_11gR2_database
ofm_frmrpts_win_11.1.2.1.0_32

Lo que quiero es los pasos para configurar Webutil para Forms 11g.


p.d: Yo ya se configurar webutil para forms 10g. Gracias de antemano por vuestra ayuda.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No consigo configurar Webutil en Forms 11g, aunque en Forms 10g si lo consegui

Publicado por Lázaro Rodríguez (1 intervención) el 14/03/2013 23:24:40
Descarga la librería "jacob.jar", esta es necesaria para que puedas usar las APIs de Windows. Cuando lo bajes, va a venir en un rar ó zip con otros archivos. En mi caso, yo solo saco 2 archivos, el jacob.jar y el jacob.dll ambos los coloco en el directorio webutil que está en el directorio forms, dentro del home de oracle, por ejemplo:
%ORACLE_HOME%\forms\webutil\
Una vez ahí los archivos, procede a firmar el jacob.jar. En este mismo directorio viene un batch llamado sign_webutil.bat, lo que debes hacer es abrir una línea de comandos e ir al directorio de webutil, una vez ahí lo ejecutas de la siguiente forma:
> sign_webutil jacob.jar
... va a tardar unos segundos en firmar la librería. Una vez finalizado el proceso, te hará un respaldo del jacob.jar como jacob.jar.old y te creará un jacob.jar nuevo ya firmado para ser usado en tu servidor.
Ahora lo que debes hacer es mover el archivo jacob.jar del directorio webutil al directorio java (donde por default residen los jars)
%ORACLE_HOME%\forms\java\
Recuérda que debes agregar la ruta del jacob.jar en la variable CLASSPATH del archivo default.env
...con estos pasos no debes tener problemas para usar webutil
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar