PLC's - Problema FB OMRON

   
Vista:

Problema FB OMRON

Publicado por Jose Angel (6 intervenciones) el 04/01/2008 10:15:39
Buenas me he creado un FB en OMRON para hacer los distintos tipos de temporizadores que tiene siemens ya que he visto a omron un poco pobre en esto.

Tampoco que hecho grandes cosas con omron y no estoy muy acostumbrado a él mucho pero os comento:

En el FB que me he creado, tengo

Entradas:

EN (BOOL)
INICIO (BOOL)
Reset (BOOL)
Pausa (BOOL)
Tiempo (DINT)

Salidas:

Todas son de tipo BOOL y son las salidas de los 5 tipos de temporizadores que tiene Siemens (SI, SV, SE, SS y SA) y ENO tambien BOOL

Internas:

Memorizado de inicio (BOOL)
Comienzo de calculo (BOOL)
Calculo tiempo actual (DINT)

Externas:

Solo uso el P_0_1s para saber cuantas decimas de segundo han pasado y saber el tiempo.

Mi problema es que dentro del FB parece que todo está bien, pero a la hora de pasar el FB a la Seccion1 de programa, aun rellenando todas las patillas, sigue mostrandomeló la parte izda en rojo, como si hubiera algo sin terminal o mal.

Tambien me dice que hay errores en las 3 primeras lineas entradas, pero creo que estan bien puestas ya que son entradas BOOL y le he puesto entradas de contactos.

Os dejo una imagen de lo que me sale en:

http://img170.imageshack.us/img170/446/temporizadoromronpe1.jpg

Un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema FB OMRON

Publicado por keating (2 intervenciones) el 16/01/2008 19:31:03
Introdúcele a la entrada inicio de la FB el contacto 0.0 pero independiente, es decir, no lo cojas con una linea vertical de la variable de abajo.
Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema FB OMRON

Publicado por Jose Angel  (6 intervenciones) el 17/01/2008 13:55:53
Gracias por la respuesta Keating, pero de esa forma ya habia probado antes de ponerlo como tengo en la img.

Puede ser que los FBs no acepten el bit de pulso P_0_1s???

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema FB OMRON

Publicado por David (1 intervención) el 04/02/2008 17:30:20
He visto que no conectas el EN (BOOL), con un contacto siempre a ON basta, ten presente que debe de haber una direccion a todas las entradas del FB, me explico, si tienes un FB con dos entradas a parte de la EN debes indicar una direccion a cada una de ellas, de la manera que te indica Keating.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema FB OMRON

Publicado por Jose Angel (6 intervenciones) el 04/02/2008 23:10:53
Hola david

Gracias por la respuesta, ya he probado poner la patilla EN con un el P_ON (contacto siempre ON) y sigue la parte izda en rojo como si estubiera algo mal o incompleto.

un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema FB OMRON

Publicado por Jose Angel (6 intervenciones) el 14/02/2008 23:32:54
YA HE SOLUCIONADO EL ERROR, era que tanto en las entradas como en las salidas no vale con poner contactos o bobinas, hay que ponerlos como PARAMETROS DEL FB, pero ahora tengo otro problema al hacer pruebas:

La programación por dentro del FB está bien, pero no se xq me da de vez en cuando error de ciclo o algo así al simular y es como si el automata se fuera a STOP, puede ser que la funcion no aguante la admisión del dato de tiempo que tengo puesto (P_0_1s) si es asi, alguien sabe si en algun DM, marca o lo que sea, se puede leer el tiempo de ciclo que hace el automata para hacer introducirlo por la patilla P_0_1s y hacer así un calgulo????

Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar