Pascal/Turbo Pascal - vectores y suma de numeros

   
Vista:

vectores y suma de numeros

Publicado por gabriel mendonca (6 intervenciones) el 29/01/2009 17:23:09
hola necesito ayuda con este programa... el enunciado es el siguiente:

"Almacenar 15 numeros en un vector, imprimir cuantos son ceros, cuantos son negativos, cuantos positivos, imprimir ademas la suma de los negativos y la suma de los positivos"

gracias, espero una pronta respuesta!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

sorry por la tardanza

Publicado por Adrian (2 intervenciones) el 26/07/2009 16:55:59
programa hola
constantes
max=15
tipo
t_vector=arreglo[1..max] de enteros
varialbes
v:t_vector
ocupado: entero
procedimiento carga (E/S v:t_vector, E/S ocupado:entero) [esto carga el vector]
variables
i:entero
respuesta:caracter
inicio
ocpuado<- 0
repetir
si ocupado0max entonces
escribir "vector lleno"
sino
ocupado <- ocupado + 1
escribir "ingrese un numero"
leer v[ocupado]
finsi
escribir "desea ingresar mas datos y/n"
leer respuesta
hasta que respuesta= "n"
fin

procedimiento TODO (E v:t_vector, E ocupado:entero) [esto calcula todo lo q pedis]
variables
i: entero
pos,neg,cero: entero
suma_pos,suma_neg:entero
inicio
pos <- 0
neg <- 0
cero <- 0
suma_pos <- 0
suma_neg <- 0
para i =1 hasta ocupado hacer
si v[i]>0 entonces
pos <- pos + 1
suma_pos <- suma_pos + v[i]
sino
si v[i]<0 entonces
neg <- neg + 1
suma_neg <- suma_neg + v[i]
sino
cero <- cero + 1
finsi
finsi
finpara
escribir "negativos: ", neg
escribir "positivos: ", pos
escribir "ceros: ", cero
escribir "la suma de los positivos es: ", suma_pos
escribir "la suma de los negativos es: ", suma_neg
fin

inicio [este es el programa principal]

carga(v , ocupado)
TODO(v,ocupado)

fin

espero q te sirva y si no q le sirva a otro q entre despues ok eso es todo si tenes alguna duda te respondo, ok chao.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

sorry por la tardanza

Publicado por Kimberly Beltran (1 intervención) el 21/11/2012 05:41:34
amm esta hecho en pseudocodigo no?
amm lo nesesito en codificacion
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

sorry por la tardanza

Publicado por Adrian (2 intervenciones) el 26/07/2009 16:57:37
programa hola
constantes
max=15
tipo
t_vector=arreglo[1..max] de enteros
varialbes
v:t_vector
ocupado: entero
procedimiento carga (E/S v:t_vector, E/S ocupado:entero) [esto carga el vector]
variables
i:entero
respuesta:caracter
inicio
ocpuado<- 0
repetir
si ocupado0max entonces
escribir "vector lleno"
sino
ocupado <- ocupado + 1
escribir "ingrese un numero"
leer v[ocupado]
finsi
escribir "desea ingresar mas datos y/n"
leer respuesta
hasta que respuesta= "n"
fin

procedimiento TODO (E v:t_vector, E ocupado:entero) [esto calcula todo lo q pedis]
variables
i: entero
pos,neg,cero: entero
suma_pos,suma_neg:entero
inicio
pos <- 0
neg <- 0
cero <- 0
suma_pos <- 0
suma_neg <- 0
para i =1 hasta ocupado hacer
si v[i]>0 entonces
pos <- pos + 1
suma_pos <- suma_pos + v[i]
sino
si v[i]<0 entonces
neg <- neg + 1
suma_neg <- suma_neg + v[i]
sino
cero <- cero + 1
finsi
finsi
finpara
escribir "negativos: ", neg
escribir "positivos: ", pos
escribir "ceros: ", cero
escribir "la suma de los positivos es: ", suma_pos
escribir "la suma de los negativos es: ", suma_neg
fin

inicio [este es el programa principal]

carga(v , ocupado)
TODO(v,ocupado)

fin

espero q te sirva y si no q le sirva a otro q entre despues ok eso es todo si tenes alguna duda te respondo, ok chao.

pd: XD no me fije es todo sobre pascal simplemente tenes q pasarlo a ingles jeje.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

como se suman las posiciones de un vector

Publicado por mayleth (1 intervención) el 01/10/2009 01:08:47
como se suman n posiciones en un vector en pascal
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

como se suman las posiciones de un vector

Publicado por ramon (2072 intervenciones) el 21/11/2012 16:33:00
Ejemplo:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
uses
      crt;
var
vector : array[1..10] of integer;
 n : integer;
 resul : longint;
  begin
  {rellenamos el vector}
     for n := 1 to 10 do
     vector[n] := n * 2;
   {sumamos el vector}
  resul := 0;
  for n := 1 to 10 do
  resul := resul + vector[n];
  {presentamon suma}
  writeln(resul);
   readln;
 end.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar