PostgreSQL - Uggrade 81 a 82 / Movimiento de datos.

   
Vista:

Uggrade 81 a 82 / Movimiento de datos.

Publicado por miguel coluccelli pozuelo (1 intervención) el 15/09/2008 10:37:07
Hola.
Espero que podáis ayudarme porque estoy desesperado.

Esta es la situación:
Estoy intentando hacer una migración de pg81 a 82. Amboss están ya instalados y ahora quiero pasar una base que se llama FNWB_2 de la 81 a la 82. La 82 va a ser un cluster que ya tiene instalado y funcionando el pgpool y hace de balanceador y replicador. Primero, lo que quiero es pasar los datos de mi vieja 81 al nodo 1 del cluster y ahí comienzan los problemas. Estoy utilizando lo siguiente:

En 81:
1. su - postgres
2. pg_dump -Fc -n USER -E LATIN1 -U USER -f /var/lib/pgsql/fnac.dump.cluster FNWB_2

En 82
cd /var/lib/pgsql
scp -p fancpg2.fnac.es:/var/lib/pgsql/fnac.dump.cluster
su - postgres
pg_restore -Fc -c -n fnac -d FNWB_2 -v /var/libpgsql/fanc.dump.cluster

El problema es que cuando termina el restore me dice que "ha omitido 2459 errores"

Después, para sincronizar con el otro nodo del cluster, estoy usando:

export RSYNC_RSH=ssh
/usr/bin/rsync -avt -lHpogDtx fnacdb1_lan.fnac.es:/var/lib/pgsql/data /var/lib/pgsql/data
/usr/bin/rsync -avt -lHpogDtx fnacdb1_lan.fnac.es:/var/lib/pgsql/fnac /var/lib/pgsql/fnac

No sé si esto es correcto o estoy metiendo la pata porque todavía es peor.
NO sé si ayuda decir que estoy haciendo varios test y que, claro, para cada test, después tengo que borrar y recrear la bd que he creado en el nodo 1 del cluster (y si he hecho la sincronización, la del nodo 2 tb.) Al recrearla con createdb, también instalo los createland plpgsql, plperl y el perlu, además del dblink, tsearch2, el tablefunc y el pg_trgm. Es posible que al borrar las bases de test y recrearlas esté borrando cosas que no debería?
Por favor, necesito ayuda.
Muchass gracias.
Miguel

In the other hand, I´m making some test before the jump to production. In each test, I´m droping the 82 database. After that, I´m installing all the createlang (plpgsql, plperl, plperlu) and the talefunc, the tsearch2, the pg_trgm and the dblink. I´m forgetting anything? Could be here the problem during the restore and the pg_dump?
Tks a lot for your help. I wait for your news. Pls, help!!!!!!!!
Miguel, from Spain.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de PostgreSQL
- Cursos de PostgreSQL
- Temas de PostgreSQL
- Chat de PostgreSQL
información
Cursos y Temas de PostgreSQL
- PostgreSQL 8.2.5 Documentation
- PostgreSQL Práctico
- Introducción a PostgreSQL

Hola miguel

Publicado por maria (2 intervenciones) el 12/11/2009 20:39:58
Hola miguel como estas he leido tu pregunta y vi que ya instalaste el pgpool para la replicacion nosotros estamos en ese proceso de migrar nustras base de datos de 8.1 a 8.4 y bueno queremos instalar el pgpool para hacer las replicas me preguntaba si me podrias decir que tal te ha resultado el pgpool y orientar en la configuracion ya que he bajado algunos manuales y de verdad estoy medio perdida. de antemano muchas gracias miguell
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar