PostgreSQL - Error: Conexion remota PostgreSQL

   
Vista:

Error: Conexion remota PostgreSQL

Publicado por ioel (1 intervención) el 08/07/2010 09:14:20
Buenos días,

Tengo establecidas dos conexiones para una misma aplicación:

1. localhost, 127.0.0.1(puerto 5432, es el que viene por defecto para postgres): Funciona correctamente.

2. Con otro servidor(192.168.x.xxx): En esta me salta el erro "org.postgresql.util.PSQLException: El intento de conexión falló.". Yendo un poco más alla me salta el error: "java.sql.SQLException: No suitable driver found for ", es decir, no se porque no me carga los drivers.

1. Lo que tengo instalado en las dos máquinas:

JVM: version 6 update 17.

PostgreSQL 8.4.

Windows XP version 5.1 running on x86.

2. Lo que he comprobado en el otro servidor:

En herramientras administrativas: Servicio iniciado, usuario postgres creado, posiblidad de crear un ODBC basado en postgreSQL, Controladores creados tanto ANSI como UNICODE.

Ping correcto.

La unica diferencia entre las dos aplicaciones es lo siguiente:

192.168x.xxx: URL_bd = "jdbc:postgresql://192.168.x.xxx:5432/obras";

localhost: URL_bd = "jdbc:postgresql://localhost:5432/obras_pruebas/";

Mi servidor de bbdd "postgreSQL 8.4" esta instalado con el mismo usuario y contraseña en las dos máquinas y desde la máquina "localhost" puedo ver y manipular(insert, update, select, ...) los datos de la bbdd del servidor 192.168.x.xxx.

En el archivo pg.hba.conf vienen estas líneas en las que se define el acceso:

# IPv4 local connections:
host all all 127.0.0.1/32 md5
host all all 0.0.0.0/0 md5
host all all 0.0.0.0 0.0.0.0 md5
host all all 192.168.xx.xx/32 md5

En el archivo postgresql.conf:

# - Connection Settings -

listen_addresses = '*' # what IP address(es) to listen on;
# comma-separated list of addresses;
# defaults to 'localhost', '*' = all
# (change requires restart)
port = 5432 # (change requires restart)
max_connections = 100 # (change requires restart)

Segun estos dos archivos, en principio, debería poder conectarme, mediante pgadmin III de mi maquina local lo hago, correctamente pero desde la aplicación me sigue saltando el mismo error.

Un saludo y buen día.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder