Power Builder - Problemas con decimales

   
Vista:

Problemas con decimales

Publicado por Cibernauta (45 intervenciones) el 10/01/2010 18:13:14
Hola amigos,

Tengo en mi pc el Windows 7 y he creado una maquina virtual XP la cual trabaja muy bien.
En la pc virtual he instalado la BD Oracle 10g y para manejar la data estoy usando TOAD. Osea que la misma pc virtual es mi servidor de BD y a la vez la uso de cliente para programar.

El caso es que ha pesar de haber tenido cuidado en que la configuracion regional sea la correcta, en el TOAD puedo notar que los decimales los separa con "coma" en lugar de "punto".

Ya he inestigado por la web y he hecho los cambios que me piden: modificar en el regedit el NLS_LANG para que diga AMERICAN_AMERICA.ISO.....

Tambien he modificado el SPFILE para que el NLS_NUMERIC_CHARACTERS tenga los caracteres ".,"

Tambien he hecho ALTER SESSION SET NLS_NUMERIC_CHARACTERS.

Ya no se que mas hacer para solucionar el problema.

Agradecere que me ayuden para los numeros se muestren asi: 125,478.52 en lugar de 125.478,.52

Saludos

Cibernauta
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con decimales

Publicado por miguell (108 intervenciones) el 16/01/2010 00:33:46
has mirado si las setting regionales de la máquina virtual XP están en 'americano'???

(o sea tal cual lo harías desde el panel de control en una instalación normal de XP??????)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar