Power Builder - Error en el retrieve

   
Vista:

Error en el retrieve

Publicado por Guadalupe Méndez (37 intervenciones) el 16/08/2010 17:03:27
Hola a todos

Seguramente alguien me puede ayudar, tengo una datawindow y al hacer el retrieve algunas veces me sale un error, no se a que se deba por que es solo a veces, trabajo con power builder 11.5 y postgreSQL 8.3, el error es el siguiente:

Ha ocurrido un error en la base de datos.

Codigo de error de la base de datos: 999
Mensaje de error de la base de datos:
Select Error: An invalid handle was passed in call to the database driver.

Si a alguien le ha salido o sabe como resolverlo se los agradezco mucho, repito que solo algunas veces me sale el error.

Saludos y gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Error en el retrieve

Publicado por JeinnerH (638 intervenciones) el 17/08/2010 22:20:58
Hola Guadalupe. A decir verdad no había visto ese error. Pero me suena como que se te está cayendo la conexión a la base de datos.

La base de datos está local en tu máquina?

Si no está local, puedes probar ejecutar esta misma consulta desde el servidor, a ver si también sucede lo mismo.

Si está local, revisa que no estés teniendo problemas de red con alguna otra aplicación o si por alguna razón la base de datos se desconecta.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error en el retrieve

Publicado por Guadalupe Méndez (37 intervenciones) el 17/08/2010 23:05:08
Hola Jeinner

Mi base de datos está local, lo raro es que solo me pasa con ese reporte y solo algunas veces, en un momento pensé que eran los parámetros le estaba pasando uno de más, pero ya lo arreglé y me sigue saliendo el error, pero no tengo un parámetro como para decir cuando por que aunque haga exactamente lo mismo que cuando me salió el error ya no vuelve a salir hasta después de un tiempo. Gracias por tu respuesta, seguiré buscandole.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error en el retrieve

Publicado por JeinnerH (638 intervenciones) el 17/08/2010 23:52:14
Intenta dejar la aplicación abierta durante algún tiempo, SIN HACER NADA. Luego de un rato, generas el reporte para verificar si es que se está desconectando automáticamente.

Que tiene de especial este reporte?, es más pesado en cuanto a procesamiento de datos que los otros que no te dan error?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error en el retrieve

Publicado por Guadalupe Méndez (37 intervenciones) el 18/08/2010 18:39:55
Gracias Jeinner

Ya intenté lo que me dijiste y no ocurrió el error, seguiré probando, si me sigue saliendo tendré que volver a hacer mi reporte por que no encuentro una explicación lógica.

No tiene nada de especial el reporte, es un composite pero tengo otros parecidos y no me generan ese error, tampoco está pesado.

De cualquier manera gracias por tus respuestas.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error en el retrieve

Publicado por Fatim (70 intervenciones) el 27/09/2010 17:34:56
Guadalupe pudiste resolver este error?? porque tengo el mismo problema.... Espero puedas compartir si lo has resuelto ya que tampoco le encuentro explicacion...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error en el retrieve

Publicado por Guadalupe Méndez (37 intervenciones) el 29/09/2010 15:48:56
Hola Fatim

No pude resolver el error, lo malo es que no siempre pasa, no hay un distingo como para decir cuando va a pasar o cuando no, y solo me pasa con un reporte.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar