Power Builder - Problema con len blob

   
Vista:

Problema con len blob

Publicado por Guillermo Ramirez Melendez guichigachi@gmail.com (1 intervención) el 16/10/2012 16:24:34
Hola a todos:
Tengo una aplicación donde guardo archivos pdf a la base de datos en un campo byte de informix, el problema viene al recuperar la información, hago un selectblob y lo asigno a una variable blob, el problema viene al momento de usar la funcion len, pues en cuanto la invoca el programa truena totalmente la aplicación sin explicación alguna únicamente mostrando un mensaje que dice Power Builder 12 has stopped working.

Cualquier consejo lo agradeceré.

Saludos!!

Guillermo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema con len blob

Publicado por JeinnerH jhidalgo@excelteccr.com (638 intervenciones) el 16/10/2012 17:07:40
Prueba usando LenEX

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problema con len blob

Publicado por Guillermo Ramirez (15 intervenciones) el 17/10/2012 00:46:52
Gracias JeinnerH por la respuesta, pero la funcion no se encuentra entre las que esta por default en PB 12, por otro lado comento que ya se resolvio el problema, este fue que en el where del selectblob el nombre de una columna estaba incorrecto y de cualquier modo el objeto transaccion reportaba que la consulta estaba bien, pero lo peor es que ponia basura en la variable BLOB por lo que cualquier funcion que se usara para manipularla generaba el cierre de la aplicacion.

Gracias a todos por su ayuda y espero que sirva el tip en caso de que le suceda a alguien mas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar