Pseudocódigo/Diagramas de Flujo - ayuda..urgente

   
Vista:

ayuda..urgente

Publicado por mariana (1 intervención) el 15/05/2010 16:09:57
necesito hacer este diagrama de flujo lo empece pero nose como terminarlo:
Realizar un programa que permita liquidar sueldos a 10 empleados de una fabrica y conocer el total de sueldos a pagar por el empresario y el total de descuentos a aportar.
Ingresar: nombre de empleado y sueldo bruto (se aplican descuentos del 15% sobre el sueldo bruto)

y este:
Realizar un programa que permita liquidar expensas de un edificio de N departamentos. Se ingresará el total de expensas a pagar y el porcentaje que le corresponde a cada departamento. Mostrar por pantalla el Nro. de departamento y el importe a pagar.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ayuda..urgente

Publicado por luishoracio (6 intervenciones) el 08/07/2010 00:44:31
Buenas tardes

Aqui estan los dos revisalos y me avisas

Primero

inicio
nombre=" "
sueldo=0,total=0,suma=0,aporte=0
i=0

para i=1 hasta 10
lea nombre,sueldo
suma=suma+sueldo
aporte=aporte+(sueldo*0.15)
fin para

imprimir "total de sueldos"
imprimir suma
imprimir "total aporte"
imprimir aporte

fin

Segundo

inicio
expensas=0
importe=0
porcentaje=0
n=0
lea n
para i=1 hasta n
lea expensas
lea porcentaje
importe=expensas*(porcentaje/100)
imprima "Apartamento No" i
imprima "Importe a pagar" importe
fin para

fin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar