Pseudocódigo/Diagramas de Flujo - AYUDA POR FAVOR

   
Vista:

AYUDA POR FAVOR

Publicado por yolgrelis yescobar@hotmail.com (2 intervenciones) el 09/06/2011 22:00:21
hacer un algoritmo en pseudocodigo que determine la ganadora de 25 participantes de un concurso de belleza en la uah, donde votan los alumnos, profesores, directivo y obrero se pide:

1)determinar la cantidad de votos de cada participante.
2) participante ganadora.
3) el % de voto de cada participante

MUCHAS. GRACIAS
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Henry

AYUDA POR FAVOR

Publicado por Henry (3 intervenciones) el 10/06/2011 03:24:36
Buenas noches Yolgrelis
Lo que planteas es un poco largo, se puede resumir con arreglos, pero no se hasta que punto conoces de arreglos. te envío el pseudocodigo sin utilizar arreglos. Si conoces de arrreglos me puedes avisar y te codifico el algoritmo con arreglos. ¿ Que semestre o año estas cursando en la Alejandro Humboldt?.

PSEUDOCODIGO determine la ganadora de 25 participantes de un concurso de belleza

p1=0 , p2=0 , p3=0 , p4=0 , p5=0 , p6=0 , p7=0 , p8=0 , p9=0 , p10=0 , p11=0,p12=0 , p13=0
p14=0 , p15=0 , p16=0 , p17=0 , p18=0 , p19=0 , p20=0 , p21=0 , p22=0 , p23=0 , p24=0 , p25=0
porc_1=0,porc_2=0,porc_3=0,porc_4=0,porc_5=0,porc_6=0,porc_7=0,porc_8=0,porc_9=0
porc_10=0,porc_11=0,porc_12=0,porc_13=0, porc_14=0 , porc_15=0 , porc_16=0 , porc_17=0 , porc_18=0 , porc_19=0 , porc_20=0 , porc_21=0 , porc_22=0 , porc_23=0 , porc_24=0 , porc_25=0
tot_voto=0,mayor=0
voto=" "

HACER MIENTRAS cerrar="NO"
ESCRIBIR "Seleccione su voto: "
LEER voto
tot_voto= tot_voto + 1
SI voto = participante_1 ENTONCES
p1 = p1 + 1
FINSI
SI voto = participante_2 ENTONCES
p2 = p2 + 1
FINSI
SI voto = participante_3 ENTONCES
p3 = p3 + 1
FINSI
SI voto = participante_4 ENTONCES
p4 = p4 + 1
FINSI
SI voto = participante_5 ENTONCES
p5 = p5 + 1
FINSI
SI voto = participante_6 ENTONCES
p6 = p6 + 1
FINSI
SI voto = participante_7 ENTONCES
p7 = p7 + 1
FINSI
SI voto = participante_8 ENTONCES
p8 = p8 + 1
FINSI
SI voto = participante_9 ENTONCES
p9 = p9 + 1
FINSI
SI voto = participante_10 ENTONCES
p10 = p10 + 1
FINSI
SI voto = participante_11 ENTONCES
p11 = p11 + 1
FINSI
SI voto = participante_12 ENTONCES
p12 = p12 + 1
FINSI
SI voto = participante_13 ENTONCES
p13 = p13 + 1
FINSI
SI voto = participante_14 ENTONCES
p14 = p14 + 1
FINSI
SI voto = participante_15 ENTONCES
p15 = p15 + 1
FINSI
SI voto = participante_16 ENTONCES
p16 = p16 + 1
FINSI
SI voto = participante_17 ENTONCES
p17 = p17 + 1
FINSI
SI voto = participante_18 ENTONCES
p18 = p18 + 1
FINSI
SI voto = participante_19 ENTONCES
p19 = p19 + 1
FINSI
SI voto = participante_20 ENTONCES
p20 = p20 + 1
FINSI
SI voto = participante_21 ENTONCES
p21 = p21 + 1
FINSI
SI voto = participante_22 ENTONCES
p22 = p22 + 1
FINSI
SI voto = participante_23 ENTONCES
p23 = p23 + 1
FINSI
SI voto = participante_24 ENTONCES
p24 = p24 + 1
FINSI
SI voto = participante_25 ENTONCES
p25 = p25 + 1
FINSI
ESCRIBIR "¿cerrar la votación? SI/NO"
LEER cerrar
FINMIENTRAS

COMENTARIO determinar la ganadora, porcentaje de votos de cada participante

SI p1 > mayor ENTONCES
mayor = p1
ganadora = participante_1
FINSI
SI p2 > mayor ENTONCES
mayor = p2
ganadora = participante_2
FINSI
SI p3 > mayor ENTONCES
mayor = p3
ganadora = participante_3
FINSI
SI p4 > mayor ENTONCES
mayor = p4
ganadora = participante_4
FINSI
SI p5 > mayor ENTONCES
mayor = p5
ganadora = participante_5
FINSI
SI p6 > mayor ENTONCES
mayor = p6
ganadora = participante_6
FINSI
SI p7 > mayor ENTONCES
mayor = p7
ganadora = participante_7
FINSI
SI p8 > mayor ENTONCES
mayor= p8
ganadora = participante_8
FINSI
SI p9 > mayor ENTONCES
mayor = p9
ganadora = participante_9
FINSI
SI p10 > mayor ENTONCES
mayor = p10
ganadora = participante_10
FINSI
SI p11 > mayor ENTONCES
mayor = p11
ganadora = participante_11
FINSI
SI p12 > mayor ENTONCES
mayor = p12
ganadora = participante_12
FINSI
SI p13 > mayor ENTONCES
mayor = p13
ganadora = participante_13
FINSI
SI p14 > mayor ENTONCES
mayor = p14
ganadora = participante_14
FINSI
SI p15 > mayor ENTONCES
mayor = p15
ganadora = participante_15
FINSI
SI p16 > mayor ENTONCES
mayor = p16
ganadora = participante_16
FINSI
SI p17 > mayor ENTONCES
mayor = p17
ganadora = participante_17
FINSI
SI p18 > mayor ENTONCES
mayor = p18
ganadora = participante_18
FINSI
SI p19 > mayor ENTONCES
mayor = p19
ganadora = participante_19
FINSI
SI p20 > mayor ENTONCES
mayor = p20
ganadora = participante_20
FINSI
SI p21 > mayor ENTONCES
mayor = p21
ganadora = participante_21
FINSI
SI p22 > mayor ENTONCES
mayor = p22
ganadora = participante_22
FINSI
SI p23 > mayor ENTONCES
mayor = p23
ganadora = participante_23
FINSI
SI p24 > mayor ENTONCES
mayor = p24
ganadora = participante_24
FINSI
SI p25 > mayor ENTONCES
mayor = p25
ganadora = participante_25
FINSI

ESCRIBIR "Participante ganadora: "
ESCRIBIR ganadora
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_1
ESCRIBIR p1
ESCRIBIR "% representativo: "
ESCRIBIR porc_1 = p1 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_2
ESCRIBIR p2
ESCRIBIR "% representativo: "
ESCRIBIR porc_2 = p2 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_3
ESCRIBIR p3
ESCRIBIR "% representativo: "
ESCRIBIR porc_3 = p3 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_4
ESCRIBIR p4
ESCRIBIR "% representativo: "
ESCRIBIR porc_4 = p4 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_5
ESCRIBIR p5
ESCRIBIR "% representativo: "
ESCRIBIR porc_5 = p5 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_6
ESCRIBIR p6
ESCRIBIR "% representativo: "
ESCRIBIR porc_6 = p6 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_7
ESCRIBIR p7
ESCRIBIR "% representativo: "
ESCRIBIR porc_7 = p7 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_8
ESCRIBIR p8
ESCRIBIR "% representativo: "
ESCRIBIR porc_8 = p8 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_9
ESCRIBIR p9
ESCRIBIR "% representativo: "
ESCRIBIR porc_9 = p9 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_10
ESCRIBIR p10
ESCRIBIR "% representativo: "
ESCRIBIR porc_10 = p10 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_11
ESCRIBIR p11
ESCRIBIR "% representativo: "
ESCRIBIR porc_11 = p11 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_12
ESCRIBIR p12
ESCRIBIR "% representativo: "
ESCRIBIR porc_12 = p12 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_13
ESCRIBIR p13
ESCRIBIR "% representativo: "
ESCRIBIR porc_13 = p13 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_14
ESCRIBIR p14
ESCRIBIR "% representativo: "
ESCRIBIR porc_14 = p14 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_15
ESCRIBIR p15
ESCRIBIR "% representativo: "
ESCRIBIR porc_15 = p15 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_16
ESCRIBIR p16
ESCRIBIR "% representativo: "
ESCRIBIR porc_16 = p16 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_17
ESCRIBIR p17
ESCRIBIR "% representativo: "
ESCRIBIR porc_17 = p17 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_18
ESCRIBIR p18
ESCRIBIR "% representativo: "
ESCRIBIR porc_18 = p18 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_19
ESCRIBIR p19
ESCRIBIR "% representativo: "
ESCRIBIR porc_19 = p19 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_20
ESCRIBIR p20
ESCRIBIR "% representativo: "
ESCRIBIR porc_20 = p20 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_21
ESCRIBIR p21
ESCRIBIR "% representativo: "
ESCRIBIR porc_21 = p21 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_22
ESCRIBIR p22
ESCRIBIR "% representativo: "
ESCRIBIR porc_22 = p2 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_23
ESCRIBIR p23
ESCRIBIR "% representativo: "
ESCRIBIR porc_23 = p23 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_24
ESCRIBIR p24
ESCRIBIR "% representativo: "
ESCRIBIR porc_24 = p24 * 100 / tot_voto
ESCRIBIR "Cantidad de votos de "
ESCRIBIR participante_25
ESCRIBIR p25
ESCRIBIR "% representativo: "
ESCRIBIR porc_25 = p25 * 100 / tot_voto
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Henry

AYUDA POR FAVOR

Publicado por Henry (3 intervenciones) el 10/06/2011 03:56:52
Faltó inicializar la variable cerrar. Coloca esta expresión despues de la ultima variable declarada.
cerrar = "NO"
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

AYUDA POR FAVOR

Publicado por yolgrelis (2 intervenciones) el 11/06/2011 07:30:52
si conozco los arreglo lo que pasa es que tengo tiempo que no programo y hay cosas que no recuerdo.. de verdad gracias por lo que me mandaste. lo tomare en cuenta y estoy en el 5º semestre por equivalencia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Henry

AYUDA POR FAVOR

Publicado por Henry (3 intervenciones) el 11/06/2011 18:25:29
Buenos dias Yolgrelis
Te envío el algoritmo utilizando arreglos

PSEUDOCODIGO determine la ganadora de 25 participantes de un concurso de belleza

tot_voto=0 , mayor=0 , x = 0
cerrar="NO"
voto=""
tv[25] , p{25]

COMENTARIO: LLenar el arreglo con los nombres de las participantes. Tienes dos(2) opciones:
En una sola linea llenas el arreglo, o individual elemento por elemento. Debes tomar una sola opción.
Comentario 1ra opción:
p[ ]={"María","Josefina","Laura",Teresa",Luisa","Josefa","Aura","Yoselin","Aimara","Carmen",Evelia",
"Yuslary",Elena","Carolina","Katty",Moraima","Nelly","Zaida","Maruja","Mariana",Mariany",Margot",
"Katiuska","Trina","Rebeca"}

Comentario 2da. opción:
p[1]="María"
p[2]="Josefina"
p[3]="Laura"
p[4]="Teresa"
p[5]="Luisa"
p[6]="Josefa"
p[7]="Aura"
p[8]="Yoselin"
p[9]="Aimara"
p[10]="Carmen"
p[11]=Evelia"
p[12]="Yuslary"
p[13]=Elena"
p[14]="Carolina"
p[15]="Katty"
p[16]=Moraima"
p[17]="Nelly"
p[18]="Zaida"
p[19]="Maruja"
p[20]="Mariana"
p[21]="Mariany"
p[22]="Margot"
p[23]="Katiuska"
p[24]="Trina"
p[25]="Rebeca"

HACER MIENTRAS cerrar="NO"
ESCRIBIR "Seleccione su voto: "
LEER voto
tot_voto= tot_voto + 1

HACER PARA x = 1 hasta 25
SI voto = p[ x ] ENTONCES
tv[ x ] = tv[ x ] + 1
FINSI
FINPARA

ESCRIBIR "¿cerrar la votación? SI/NO"
LEER cerrar
FIN MIENTRAS

COMENTARIO: determinar la ganadora

HACER PARA x = 1 hasta 25
SI tv[ x ] > mayor ENTONCES
mayor = tv[ x ]
ganadora = p[ x ]
FINSI
FIN PARA

COMENTARIO: Mostrar la ganadora, cantidad de votos de cada participante y % representativo.

ESCRIBIR "Participante ganadora: "
ESCRIBIR ganadora

HACER PARA x = 1 hasta 25
ESCRIBIR "Cantidad de votos de "
ESCRIBIR p[ x ]
ESCRIBIR tv[ x ]
ESCRIBIR "% representativo: "
ESCRIBIR ( tv[ x ] * 100 / tot_voto)
FIN PARA
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

AYUDA POR FAVOR

Publicado por yolgrelis (1 intervención) el 11/06/2011 21:33:51
muchas gracias corazon de verdad eres de gran ayuda.. te tendre en cuenta para alguna otra consulta o duda henry es un placer. cuidate
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar