Pseudocódigo/Diagramas de Flujo - Problemas al invertir una cadena de caracteres en pseint.

   
Vista:

Problemas al invertir una cadena de caracteres en pseint.

Publicado por Jesús Orlando jesus9711@live.com.mx (1 intervención) el 27/04/2013 19:20:24
Hola, verán, tengo de tarea hacer un pseudocodigo en pseint que me invierta una cadena de caracteres utilizando los arreglos. He intentado hacerlo por mi mismo como todos mis demás trabajos pero este lo veo un poco imposible ya que no logro hacer que funcione. Este el el pseudocodigo en el que he trabajado:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Proceso Palabra_Invertida
	Dimension palabra_invertida[100];
	Escribir "Ingresa el numero de letras que tendra la palabra";
	Leer num_letras;
	i=0;
	Repetir
		Escribir "Escriba la primera letra de su palabra";
		Leer letra;
		palabra_invertida[i]=letra;
		Escribir palabra_invertida[i];
	Hasta Que num_letras
	Para j<-i Hasta 1 Con Paso -1 Hacer
		Escribir palabra_invertida[j]
	FinPara
FinProceso


No puedo hacer que funcione ya que me marca error (Lin 4 (inst 1): ERROR 120: No coinciden los tipos.) Y no se me ocurre como solucionarlo ya que mi mente se cerro . Espero me puedan ayudar antes de las 3 de la tarde de este día, tengo que mandarlo antes de esa hora. Saludos y gracias por su ayuda.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problemas al invertir una cadena de caracteres en pseint.

Publicado por Alejandro Caro (1 intervención) el 10/12/2013 20:03:47
Proceso Palabra_Invertida
Dimension palabra_invertida[100];
Definir num_letras, i, j Como Enteros;
Definir palabra_invertida Como Cadena;
Definir letra Como Caracter;
Escribir "Ingresa el numero de letras que tendra la palabra";
Leer num_letras;
i<-0;
Repetir
Escribir "Escriba la ",i+1," letra de su palabra";
Leer letra;
palabra_invertida[i]<-letra;
Escribir palabra_invertida[i];
i <- i + 1;
Hasta Que i = num_letras
Escribir "";
Para j<-i Hasta 1 Con Paso -1 Hacer
Escribir palabra_invertida[j-1];
FinPara
FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar