Pseudocódigo/Diagramas de Flujo - Ayuda con algoritmo

   
Vista:

Ayuda con algoritmo

Publicado por Adrian (1 intervención) el 31/07/2014 04:54:54
Saludos a todos.

Tengo el siguiente problema, necesito hacer un algoritmo para un cine que tiene tres salas, la sala 1 y2 tienen capacidad para 250 personas y la 3 para 100, el modulo debe chequear la disponibilidad de asientos segun lo que pida el cliente (fecha de reservacion y cantidad de personas o asientos a reservar) ya he avanzado con Pse Int sin embargo hay algo que no me funciona y no se que es. Por eso recurro a la ayuda de ustedes porque ya me estoy volviendo loco.

Adjunto el codigo y les agradezco la ayuda.

Proceso sin_titulo
cantidadasientos<-ENTERO
Fechatanda<-fecha
sala<-ENTERO
diasemana<-ENTERO
capacidadsala<-ENTERO
listaasientos<-cadena
asientosdisponibles<-ENTERO
reservar<-cadena
Escribir 'Inserte la fecha de la funcion'
Leer Fechatanda
Escribir 'Inserte el numero de sala'
Leer sala
Si sala=1 Y sala=2 Entonces
capacidadsala<-250
Sino
capacidadsala<-100
FinSi
listasientos<-vacio
Si sala=1 Entonces
Para numeroasiento<-1 Hasta asiento Con Paso capacidadsala Hacer
asiento<-()
Si sala=() y asiento=() Y diasemana=() Entonces
listaasientos<-listaasientos
Sino
asientosdisponibles<-asientosdisponibles+1
FinSi
FinPara
Sino
Si sala=2 Entonces
Para numeroasiento<-1 Hasta asiento Con Paso capacidadsala Hacer
asiento<-()
Si sala2=() Y asiento=() Y disemana=() Entonces
listaasientos<-listaasientos
Sino
asientosdisponibles<-asientosdisponibles+1
FinSi
FinPara
Sino
Para numeroasiento<-1 Hasta asiento Con Paso capacidadsala Hacer
asiento<-()
Si sala2=() Y asiento=() Y disemana=() Entonces
listaasientos<-listaasientos
Sino
asientosdisponibles<-asientosdisponibles+1
FinSi
FinPara
FinSi
FinSi
Si asientosdisponibles>cantidadasientos Entonces
Escribir 'Lista de asientos:',listaasientos
Escribir 'Cantidad de asientos disponibles:',asientosdisponibles
Escribir '¿Desea Reservar? S/N'
Leer reservar
Si reservar='S' Entonces
reservarasientos<-diasemana
reservarasientos<-sala
reservarasientos<-cantidadasientos
Sino
Escribir 'Fin Gracias'
FinSi
Sino
Escribir 'No hay disponibilidad de asientos para la cantidad solicitada.'
Escribir 'Cantidad de asientos disponibles: ',asientosdisponibles
FinSi
FinProceso
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder