Pseudocódigo/Diagramas de Flujo - Ayuda con este programa

   
Vista:

Ayuda con este programa

Publicado por Pamela (3 intervenciones) el 16/06/2016 21:02:47
Hola chicos, me gustaria que me ayuden en la resolucion de los siguiente problemas ya que no se donde podria aplicar el bucle y el mientras.

1) En un aula hay n alumnos. Se le solicita a cada uno que indique su edad (valor entero). Mostrar la menor de las n edades. Hallar y mostrar el promedio de las edades.

2) Se tiene un conjunto de n términos y se desea hallar el resultado total.
La serie se caracteriza porque en el denominador de cada término estará un valor elevado a un determinado exponente.
Además cada término tiene su signo que puede ser positivo o negativo.

1/1^2 - 4/5^2 + 7/9^3 - 10/13^4 + ...........

Porfavor. Ayudennos :'(
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Ayuda con este programa

Publicado por dario (10 intervenciones) el 17/06/2016 07:35:29
Te dejo el pseudocodigo

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
Inicio
	s=0
	prom=0.0 //numero real
 
	leer(numero_alumnos)
	leer(edad) //se lee la primera edad
 
	s=s+edad //se acumula la suma
	menor=edad //la variable menor toma el valor de la 1era edad
 
	para i=2 hasta numero_alumnos)
		leer(edad)
		s=s+edad
		si edad <menor
			menor=edad
		fin-si
	fin-para
	prom=s/i
 
	imprimir('La menor edad es: ',menor)
	imprimir('El promedio de edades es: ',prom)
Fin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ayuda con este programa

Publicado por jhonn jhovi_1354@hotmail.com (1 intervención) el 20/06/2016 09:11:31
Bueno, el conocimiento se comparte:
aqui esta señorita....

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
Proceso Sumafracciones
Ingrese Cantidad de Terminos
	Leer n
	k=1 //numerador
	l=1 //denominador
	p=1 //´potencia
	suma=1
	suma1=0
	suma2=0
	sumatotal=0
	para i=1 hasta n
		si i>=2 Entonces
			Repetir
				suma=suma+k
				k=k+3
			Hasta Que k>=i
				Repetir
					suma1=suma1+l
					l=l+4
				Hasta Que l>=i
 
				Repetir
					suma2=suma2+p
					p=p+1
				Hasta Que p>=i
 
				si k mod 2=0 entonces
					signo=-k/l^p
				Sino
					si k mod 2=1 entonces
						signo=k/l^p
					FinSi
				FinSi
			FinSi
			si i=1 Entonces
				j=1
			FinSi
			sumatotal=sumatotal+total
				FinPara
		resultado=j+sumatotal
		Escribir '*******************'
 
	Escribir resultado
 
FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ayuda con este programa

Publicado por dario (10 intervenciones) el 24/06/2016 05:48:44
Ejercicio Nro 2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
leer(n) //numero de terminos
i = j = e = 1
aux = 0
s = 0.0
 
mientras e <= n
	si i % 2 == 0
		aux = (i/j**e)*(-1)
	sino
		aux = (i/j**e)
	fin-si
 
	s = s + aux
	e += 1
	i += 3
	j += 4
fin-mientras
 
imprimir('La suma es ',s)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar