Redes - Distintas VLANs en el mismo switch

   
Vista:

Distintas VLANs en el mismo switch

Publicado por David (1 intervención) el 14/03/2014 12:00:59
Me estoy quebrando la cabeza de mala manera. A ver, os explico mi situación:

Poseo un switch de cisco (SG 300-10) con 10 puertos. Dado que necesito conectar dos subredes distintas en el mismo switch (192.168.1.0 y la 192.168.2.0), decidí crear VLANs independientes para que los tráficos no se crucen. De este modo, el switch queda configurado como se muestra en la imagen (perdón por la pésima calidad de la misma, acudí a la sencillez del paint):



En la VLAN 2 solo tengo conectado equipos que pertenecen a la subred 1.0, y en la VLAN 3 equipos de la subred 2.0. Todos los puertos son de acceso y untagged, por lo que, según tengo entendido, los tráficos solo se propagarán en los puertos de la respectiva VLAN, sin cruzarse entre ellos. En la VLAN 1 (default) no hay nada conectado, solo lo tengo como método de acceso al switch en caso de mal configuración (es un switch managed).

Pues aquí viene el problema. Mi PC tiene 2 tarjetas de red, una para cada una de las subredes y conectadas respectivamente a VLAN 2 y 3. Con la VLAN 2 no tengo problema. En esta tengo un puerto conectado a un router para el acceso a internet, y dispongo de internet. Por lo tanto bien. El problema viene con la VLAN 3 (subred 2). Aquí tengo conectado mi PC (2.98), una cámara IP (2.21) y una salida a un router donde hay conectado un servidor (2.10). La cámara IP la veo (hace ping) pero no el servidor. Además de vez en cuando, aunque dispongo de acceso a internet, este se corta o se me ralentiza. No hace ping al servidor si está conectado al switch, pero si conecto directamente el cable de red que viene del router del servidor a mi PC, el ping lo realiza correctamente.

El problema imagino que está en la configuración del switch, pero no logro resolverlo. ¿Lo estoy haciendo bien o hay algo que se me está escapando? ¿Es posible que, dado que es un servidor y hay acceso al mismo desde cualquier IP, se esté dando un conflicto con la IP del servidor (2.10) porque la ve desde dos puertos diferentes?

Muchas gracias de antemano, un saludo!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Redes
- Cursos de Redes
- Temas de Redes
- Chat de Redes
información
Cursos y Temas de Redes
- El protocolo TCP
- Tecnología Bluetooth
- Fibra óptica y cable UTP