Redes - Novato con vlans

   
Vista:

Novato con vlans

Publicado por Ferea (6 intervenciones) el 06/03/2016 03:48:30
Tengo un switch configurado con dos vlan (voz y datos), el equipo funciona bien si esta conectado directamente al equipo donde esta conectado el PBX.

Si yo conecto el nuevo switch que acabo de configurar por ejemplo al Switch A, B, C, ya no me funcionan los telefonos.

Si conecto un telefono a el cable en donde esta configurado la vlan de los telefonos directamente, el telefono funcionan, pero si conecto el switch y despues conecto un telefono a este switch, no me funciona, que pasa??
tengo que configurar un puerto trunk?? como o que le agrego (comandos o instrucciones)??

vlan

Espero y alguien me pueda ayuda, soy nuevo con las Vlans.

Saludos y gracias de antemano por la ayuda =)
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Redes
- Cursos de Redes
- Temas de Redes
- Chat de Redes
información
Cursos y Temas de Redes
- Tutorial de Teleproceso
- Administración de Redes TCP/IP
- Fibra óptica
Imágen de perfil de Raymundo Vasquez

Novato con vlans

Publicado por Raymundo Vasquez articuloslibre@hotmail.com (224 intervenciones) el 06/03/2016 23:59:04
Buenas noches

Usas tecnologia cisco?

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Novato con vlans

Publicado por Ferea (6 intervenciones) el 07/03/2016 04:37:52
No, estoy trabajando con equipos marca Dell...pero me imagino que en teoria y por lo que he visto trabajan muy similar.

en cisco como se haria??
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Raymundo Apolinar

Novato con vlans

Publicado por Raymundo Apolinar articuloslibre@hotmail.com (224 intervenciones) el 07/03/2016 13:29:01
Buen dia


En el route tenemos un servidor dhcp que entrega las direcciones a las diferentes vlans data y voz.

en el router usamos interfaces virtuales para cada vlan.

config-router


R1#show running-config
Building configuration...

Current configuration : 906 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
ip dhcp pool vlanvoz
network 172.16.30.0 255.255.255.0
default-router 172.16.30.1
ip dhcp pool datos
network 128.16.0.0 255.255.0.0
default-router 128.16.1.2
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
description vlan datos
encapsulation dot1Q 10
ip address 128.16.2.1 255.255.0.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 172.16.30.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


R1#wr
Building configuration...
[OK]
R1#
R1#
R1#show ru
R1#show running-config
Building configuration...

Current configuration : 906 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
ip dhcp pool vlanvoz
network 172.16.30.0 255.255.255.0
default-router 172.16.30.1
ip dhcp pool datos
network 128.16.0.0 255.255.0.0
default-router 128.16.1.2
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10 # interfacaz virtual para la vlan para la vlan 10
description vlan datos
encapsulation dot1Q 10 #vlan 10
ip address 128.16.2.1 255.255.0.0
!
interface FastEthernet0/0.20 # Interfaz virtual para la vlan 20
encapsulation dot1Q 20 # vlan 20
ip address 172.16.30.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


R1#

Config switch principal



Configuramos vtp para propagar vlans
creamos un enlace truncal entre este y router.



Switch#show ru
Switch#show running-config
Building configuration...

Current configuration : 1023 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
in.terface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!-
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end


Switch#


Segundo switch config



Switch#show running-config
Building configuration...

Current configuration : 1304 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
switchport voice vlan 10
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


Switch#


Baja packet tracert y veras el ecenario en funcionamiento.

Switch#show running-config
Building configuration...

Current configuration : 1304 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
switchport voice vlan 10
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


Switch#

para el ecenario bajar packet tracert 6 aqui y adjunto esta el ecenario en packet tracert

http://free4arab.com/?p=140570

Espero Te haya servido

Saludos,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Novato con vlans

Publicado por Perea (6 intervenciones) el 10/03/2016 04:39:42
Muchas gracias por el aporte Raymundo, pero ahora me paso lo siguiente, conecto un crossover cable and straight cable al puerto 23 de mi switch y el telefono funciona, pero si despues conecto un cable straight para conectar una pc el telefono se cae o deja de funcionar.

si conecto un cable straight o derecho, me da conexion para la red, que pasa??

no puedo tener ambos cables conectados al mismo tiempo por que uno de los dos se cae o deja de funcionar??

estas es la configuracion de mi equipo:


console#show running-config
!Current Configuration:
!System Description "Dell 24 Port Gigabit Ethernet, 2.2.0.3, VxWorks5.5.1"
!System Software Version 2.2.0.3
!
configure
gvrp enable
vlan database
vlan 2-3
exit
stack
member 1 1
exit
ip address 192.168.21.16 255.255.255.0
ip default-gateway 192.168.21.1
ip routing
interface vlan 2
name "Phones"
routing
exit
interface vlan 3
name "Data"


exit
username "admin" password 320eeb00c279bd9d69e4a980acf59bb8 level 15 encrypted
voice vlan
!
interface ethernet 1/g2
switchport access vlan 3
exit
!
interface ethernet 1/g3
switchport access vlan 3
exit
!
interface ethernet 1/g4
switchport access vlan 3
exit
!
interface ethernet 1/g5
switchport access vlan 3
exit
!
interface ethernet 1/g6


switchport access vlan 3
exit
!
interface ethernet 1/g7
switchport access vlan 3
exit
!
interface ethernet 1/g8
switchport access vlan 3
exit
!
interface ethernet 1/g9
switchport access vlan 3
exit
!
interface ethernet 1/g10
switchport access vlan 3
exit
!
interface ethernet 1/g11
switchport access vlan 3


exit
!
interface ethernet 1/g12
switchport access vlan 3
exit
!
interface ethernet 1/g13
switchport access vlan 3
exit
!
interface ethernet 1/g14
switchport access vlan 3
exit
!
interface ethernet 1/g15
switchport access vlan 3
exit
!
interface ethernet 1/g16
switchport access vlan 3
exit


!
interface ethernet 1/g17
switchport access vlan 3
exit
!
interface ethernet 1/g18
switchport access vlan 2
exit
!
interface ethernet 1/g19
gvrp enable
switchport mode general
switchport general pvid 2
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 2 tagged
voice vlan untagged
exit
!
interface ethernet 1/g20
gvrp enable
switchport mode general


switchport general pvid 2
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 2 tagged
voice vlan untagged
exit
!
interface ethernet 1/g21
gvrp enable
switchport mode general
switchport general pvid 2
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 2 tagged
voice vlan untagged
exit
!
interface ethernet 1/g22
gvrp enable
switchport mode general
switchport general pvid 2
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 2 tagged


voice vlan untagged
exit
!
interface ethernet 1/g23
gvrp enable
switchport mode general
switchport general pvid 2
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 2 tagged
voice vlan untagged
exit
!
interface ethernet 1/g24
gvrp enable
switchport mode general
switchport general pvid 2
no switchport general acceptable-frame-type tagged-only
voice vlan untagged
exit
!
interface ethernet 1/xg1


switchport mode trunk
switchport trunk allowed vlan remove 1
exit
exit

console#
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Raymundo Vasquez

Novato con vlans

Publicado por Raymundo Vasquez articuloslibre@hotmail.com (224 intervenciones) el 10/03/2016 12:46:28
Buen dia


Probaste con otro cable straight cable para verificar que el cable bien?


Saludos,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Novato con vlans

Publicado por Perea (6 intervenciones) el 23/03/2016 00:42:01
Si, pero sigue igual; si conecto uno funcionan bien, pero si conecto ambos, uno de los dos servicios se cae, alguna idea?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Raymundo Vasquez

Novato con vlans

Publicado por Raymundo Vasquez articuloslibre@hotmail.com (224 intervenciones) el 23/03/2016 12:29:19
Buen dia.


Hay no se que puede estar pasando ya que nunca he usado productor dell ni en ecenarios


Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar