SQL Server - procedimiento no ejecuta

   
Vista:

procedimiento no ejecuta

Publicado por Pablo (12 intervenciones) el 10/01/2008 21:55:35
Saludos desde Paraguay...

Buenas tardes amigos, tengo un drama, estoy ejecutando un procedimiento que he creado en sql desde el lenguaje PowerBuilder y no se esta ejecutando por algun problema que no puedo identificar, les agradeceria mucho si me pudieran ayudar, mas abajo les especifico mejor el problema...

///////////////////////////////////////////PROCESO QUE EJECUTA EL PROCEDIMIENTO////////////////////////////////
String stmn

stmn = "exec sp_generar_compra_g "+ em_desde_ini.text +","+ em_hasta_fin.text+",'"+em_fecha_ini.text+"','"+em_fecha_fin.text+"'"

EXECUTE IMMEDIATE :stmn using SQLCA;
if SQLCA.sqlcode = 0 then
MessageBox("Generación de I.V.A. Compra","Generación culminada con éxito")
else
MessageBox("Generación de I.V.A. Compra","Error en la generación verifique los permisos y los datos de entrada")
end if
///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

capture el codigo de error del sqlcode y el resultado fue -1, y he leido que si el el numero de error es -1 puede ser un problema de la base de datos, red o aplicacion, y pienso que es de mi base de datos porque he probado con otra base de datos y me ha funcionando

Les estaria eternnamente agradecido si me pueden ayudar

hasta luego...Exitos!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:procedimiento no ejecuta

Publicado por Isaias (3308 intervenciones) el 11/01/2008 00:00:32
Captura el CONTENIDO de stmn y revisa que sea correcto lo que vas a ejecutar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:procedimiento no ejecuta

Publicado por Pablo (12 intervenciones) el 11/01/2008 01:24:56
ya revise amigo y esto es lo que me pasa...

exec sp_generar_compra_g 1,2008,'01/01/2008','10/01/2008'

...aparentemente esta correcto ademas en una base de datos me ejecutta pero en la otra no
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:procedimiento no ejecuta

Publicado por Isais (3308 intervenciones) el 15/01/2008 21:53:10
Para empezar a corregir errores, maneja el formato de tus fechas en ANSI: yyyymmdd
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar