Visual Basic para Aplicaciones - Problemas para agregar formula de SUMA en Excel a traves de VBA

Life is soft - evento anual de software empresarial
   
Vista:

Problemas para agregar formula de SUMA en Excel a traves de VBA

Publicado por Caapi (5 intervenciones) el 09/06/2011 18:36:58
Buenos dìas!!

Estoy implementando una macro la cual agrega la formula de Sumar en una celda, sin embargo al momento de revisar dicha celda me doy cuenta que no repeta la cadena como formula sino que me da el error de: #¿NOMBRE?.

Lo estoy haciendo de la siguiente manera:

Range("A3").formula="=SUMA(A1:A2)"

Ojala me puedan ayudar a saber comop puedo hacerle para que pueda agregar esta formula y me la respete como tal y obtener asì la sumatoria en automàtico.

De antemano muchas gracias.

Saludos!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de JuanC

Problemas para agregar formula de SUMA en Excel a traves de VBA

Publicado por JuanC juanc2942@gmail.com (431 intervenciones) el 09/06/2011 21:08:33
probá con
Range("A3").FormulaLocal = "=SUMA(A1:A2)"

Saludos, desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antonio Masana

Problemas para agregar formula de SUMA en Excel a traves de VBA

Publicado por Antonio Masana (47 intervenciones) el 16/06/2011 07:48:20
Aunque ya solucionaste el problema, te dejo un pequeño truco que casi nunca falla: Pones la opcion grabar MACRO, ejecutas la opcion a mano, finalizas la MACRO, y ya tienes una buena parte de la solución que es mucho mejor que intertar buscarlo en la AYUDA de programa.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas para agregar formula de SUMA en Excel a traves de VBA

Publicado por Caapi (5 intervenciones) el 09/06/2011 21:29:39
Que tal Juan, muchas gracias.

Ya lo resolvi, lo que sucede es que debia de ponerlo en ingles, en lugra de Suma poner SUM, ya que es desde VB, y al momento de pasarse a Excel lo convierte a SUMA:

Range("A3").Formula = "=SUM(A1:A2)"

De todas maneras muchisimas gracias por tu respuesta.

Saludos!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Problemas para agregar formula de SUMA en Excel a traves de VBA

Publicado por Caapi (5 intervenciones) el 16/06/2011 16:04:13
Muchas gracias Antonio, toda ayuda es bien recibida y nunca es tarde. Estoy seguro que a alguien mas le servira.

Gracias y buen dìa amigo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas para agregar formula de SUMA en Excel a traves de VBA

Publicado por Thomas (1 intervención) el 08/12/2013 13:19:39


acertaste Caapi!!
muchas gracias!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas para agregar formula de SUMA en Excel a traves de VBA

Publicado por Daniel (1 intervención) el 20/11/2014 16:59:17
Gracias, a mi también me ha ayudado!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar