Visual Basic.NET - '<nombre>' no es un miembro de '<nombreClase>'

   
Vista:

'<nombre>' no es un miembro de '<nombreClase>'

Publicado por David (5 intervenciones) el 23/09/2011 19:51:07
Hola, soy nuevo en la programación en VB y estoy trabajando en la programación en tres capas, he elaborado dos modulos de un sistema (ya trabajand bien) y los tome de base para el de contactos, tengo las capas de datos y de negocios y el fragmento de codigo que adjunto es en la de presentación, me brinca el error siguiente

Error 1 'ObtieneContactos' no es un miembro de 'Contactos_Presentacion_.Contactos'. C:\...\Contactos(Presentacion)\Contactos.vb 7 49 Contactos(Presentacion)

ya me había pasado con otro modulo pero no recuerdo como lo solucioné, no se si me haga falta darle doble clic a alguno de los elementos de la ventana de diseño para que se genere algún evento o que onda, en el modo de diseño ya edite el datagridView y ya se genero el ContactosBindingSource, ojala me puedan ayudar, Gracias.

Imports Contactos_Negocios_
Public Class Contactos
Private Contactos As New Contactos

Private Sub Contactos_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
Try
ContactosBindingSource.DataSource = Contactos.ObtieneContactos()
'AQUI MARCA EL ERROR EN LO SUBRAYADO Catch ex As Exception
'En caso de error mandamos el mensaje de error en un messagebox
MessageBox.Show(ex.Message, "Error", MessageBoxButtons.OK, MessageBoxIcon.Error)
End Try
End Sub
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

'<nombre>' no es un miembro de '<nombreClase>'

Publicado por Damian (824 intervenciones) el 30/09/2011 15:31:46
Tal como te dice el error, estas llamando a una función o miembro que no esta dentro de la Clase Contactos. Habría que ver como tienes y donde, la declaración de "ObtieneContactos" ya que ahí no lo pones.
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

'<nombre>' no es un miembro de '<nombreClase>'

Publicado por David (5 intervenciones) el 21/10/2011 22:45:59
Perdón por tardar tanto en responder, el problema surgió al cambiar el nombre al Form, de llamarse Form1.vb (en el explorador de soluciones) se lo cambie y de allí se desmadro todo, funcionaba perfectamente mientras el nombre era Form1, lo cambie y ya no trabajo aún y cuando regrese el nombre a Form1, ya moví mil cosas y sigue igual, en el respaldo con nombre de Form1 perfecto, solo con el cambio se hace shit, gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar