Visual Basic - (AYUDA) Problemas Con VisualBasic!

Life is soft - evento anual de software empresarial
   
Vista:

(AYUDA) Problemas Con VisualBasic!

Publicado por Scofield (3 intervenciones) el 20/09/2008 14:17:21
Buenos días, tengo un problema con VB, os comento:

Tengo hecho un servidor de sockets en VisualBasic, tengo un flash que conecta a este visualbasic, le manda un mensaje y el visual le devuelve otro.

El problema viene cuando el visual contesta al flash, no consigo mandar ningun texto, por ejemplo, le pongo al visual que cuando reciba datos, devuelva el numero 87, y el flash en vez de recibir el 87 recibe W (W = la letra en ascii con valor 87) como puedo hacer para que el flash reciba lo que le mando? o ... como hacer que el visual envíe realmente el 87?! o directamente poder enviarle texto, no me lo coje el flash...

Lo he probado con php en vez de con flash y lo recibe bien, el problema lo tengo al recoger el valor con el flash... :(

Gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:(AYUDA) Problemas Con VisualBasic!

Publicado por igor (633 intervenciones) el 20/09/2008 17:08:57
Si recibe 87 (W) es que comunica perfectamente, solo que los datos se interpretan en ascii, asi que si mandas un 8 y un 7 en código ascii es lo que obtendrá a la salida.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:(AYUDA) Problemas Con VisualBasic!

Publicado por Scofield (3 intervenciones) el 20/09/2008 21:18:38
El problema es que soy incapaz de enviar texto desde VB al flash, solamente puedo enviar números (87 por.ej) y el flash me lo interpreta como texto.
Lo interesante sería poder enviar cualrquier cosa y recibirla tal cual, lo he hecho en php y ajax y me recibe tal cual lo envío, no se porque no me lo hace en flash.

De todas maneras, haciéndolo en flash con recibir numeros me basta, ahora el problema lo tengo al alojar el flash en una web, no puede conectarse al servidor de sockets en VB por temas de seguridad y ya no se que probar más, he puesto de 1000 maneras el crossdomain.xml y aun y asi no funciona... supongo que tendré que acabar haciendolo en ajax.

Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar