Visual Basic - Winsock

Life is soft - evento anual de software empresarial
   
Vista:

Winsock

Publicado por JP (16 intervenciones) el 12/11/2008 05:39:19
Cordial Saludo

Estoy trabajando con el control Winsock haciendo un chat. Cuando el equipo en el que programo hace de servidor, todo funciona bien, pero cuando el equipo servidor es distinto, no funciona mi programa.
A Alguien más le ha pasado eso?.

No se si me hago entender.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Winsock

Publicado por Juan Esteban (19 intervenciones) el 12/11/2008 16:41:25
generalmente, el equipo donde esta instalado visual tiene mas DLLs que un equipo comun... esas DLL (en este caso la de winsock) tienes que copiarla y registrarla en los equipos donde quieras usar el CHAT, te aseguro que eso funcionara...

Bueno, al momento de empaquetar tu proyecto en un instalable, te la la opcion de agregar las DLLs que visual sabe que le haran falta a los pcs cliente...

Hazlo, registra la DLL en el equipo donde pruebas y listo, funcionara...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Winsock

Publicado por JP (16 intervenciones) el 13/11/2008 20:17:23
Gracias por responder.

El problema no son los dll ni los ocx, ya que estos estan bien registrados, ademas he probado en equipos que tambien tienen instalado el visual basic.
Si los dll o los ocx no estuvieran registrados el programa no se podria ejecutar.

Mi problema es que solo mi equipo funciona como servidor: Cuando ejecuto en mi maquina el programa cliente, y en un equipo remoto el programa servidor, nunca se conectan. se queda a la escucha, pero nada mas.

Cuando en mi equipo ejecuto el programa servidor, y en uno remoto el cliente, funciona perfecto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Winsock

Publicado por quique (85 intervenciones) el 13/11/2008 20:41:35
Ah, pues algo tienes mal con las IPs de los equipos, así que ponlas bien, y asunto arreglado.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Winsock

Publicado por JP (16 intervenciones) el 14/11/2008 00:28:00
Las IP estan buenas. Fue lo primero que revise
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar