Visual Basic - visual basic con excel

Life is soft - evento anual de software empresarial
   
Vista:

visual basic con excel

Publicado por Beatriz (1 intervención) el 18/09/2007 10:34:07
Hola, estoy intentando rellenar un rango de celdas en excel mediante visual basic. La instrucción que utilizo es la siguiente:

LibroResultado.Worksheets(1).Range("d2", "d3").Formula = "=PROMEDIO(A2:B2)"

Cuando abro el fichero excel en el rango está la fórmula pero me sale como un error de nombre, sin embargo si hago doble clic sobre una celda desaparece el error y se obtiene el resultado correcto. ¿Alguien me puede decir que ocurre para que no me aparezca correctamente el resultado desde el principio? Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:visual basic con excel

Publicado por Nicolás Soto (13 intervenciones) el 18/09/2007 13:44:55
Buen día Beatriz, Intenta de la siguiente manera:

LibroResultado.Worksheets(1).Range("d2", "d3").Formula = "=AVERAGE(A2:B2)"

espero que solucione tu inconveniente.

slds
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar