Visual Basic - PROBLEMA CON ADODC Y DATAGRID

Life is soft - evento anual de software empresarial
   
Vista:

PROBLEMA CON ADODC Y DATAGRID

Publicado por Antonio (1 intervención) el 20/02/2008 19:36:48
Buenas:

En primer lugar dar las gracias por lo que me estais ayudando en el proyecto visual basic (el primero que hago) que estoy desarrollando. Tengo un problema que me gustaría poner a vuestra consideración:

Tengo un formulario desde donde se gestionan los expedientes de mi proyecto. En dicho formulario además de botones para dar de alta, de baja y modificar expedientes incluí un Datagrid y un adodc de forma que a través del adodc hacía la conexión con la base de datos, también a través de la propiedad recordsource del adodc le pasaba la expresión sql y luego asignaba el adodc al datagrid a través de la propiedad datasource del mismo.

Bien esto en el ordenador en que tengo instalado visual basic funciona sin problemas y muestra los registros en el datagrid, lo curioso es que cuando compilo el programa y lo hago correr en un ordenador sin visual basic instalado no me muestra los registros, aparece en blanco como si no rescatara ningún dato.

Después de dar muchas vueltas y comprobar que las opciones de alta de expedientes (que requieren conexión con la misma base de datos) funcionaban correctamente llegué a la conclusión que el problema era del adocd ya que en la opción de alta de expediente no lo usaba sino que usaba una conexión del tipo:

"Set cnnCli = New ADODB.Connection
ruta_base = ""
Nombre_BD = "tablasvb6.mdb"
cnnCli.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & ruta_base & Nombre_BD & ";Persist Security Info=False"
cnnCli.Open"

Bueno las preguntas que quería haceros son:

1. ¿Estoy en lo cierto cuando pienso que el problema es del adodc?
2. ¿Estará el problema en la ruta de la conexión?
3. Si es así, ¿Podéis echarme una mano? No me apetece tener que borrar el adodc y hacerlo de la forma anterior porque ya tengo programado acciones de refresh del mismo para hacer búsquedas.

Perdón por la extensión pero quería que quedara claro mi problema y gracias por vuestra ayuda.

Saludos

Antonio
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:PROBLEMA CON ADODC Y DATAGRID

Publicado por gustavo (218 intervenciones) el 24/02/2008 02:15:33
puede ser la ruta de la base de datos, te sugiero que en el codigo del programa enrrutes el ConnectionString del adodc para asegurar la ubicacion de bd.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar