Visual CSharp .NET - [Problema] The process cannot access the file.

   
Vista:

[Problema] The process cannot access the file.

Publicado por RatB (2 intervenciones) el 15/12/2015 01:01:43
Hola a todos. Estoy empezando a aprender a programar en C# con Visual Studio 2015. Tras construir una sencilla aplicación (Build Solution [F6]) ya no puedo probarla ni hacer nada ya que me salta el error "Unable to copy file "obj\Debug\IntroToCSharp.exe" to "bin\Debug\IntroToCSharp.exe". The process cannot access the file 'bin\Debug\IntroToCSharp.exe' because it is being used by another process."

Miro el administrador de tareas y aparecen los procesos (en este caso IntroToCSharp.exe) y no puedo terminarlos. Tampoco vía taskkill. Aunque cierre Visual Studio siguen apareciendo y no hay manera de quitarlos salvo que reinicie, tras lo cual puedo probar la aplicación pero solamente una vez, ya que después me vuelve a saltar el mismo error.

Si ejecuto la aplicación (en este caso IntroToCSharp.exe) desde el explorador no tengo ningún problema siempre y cuando lo haga antes de iniciarlo a través de Visual Studio, si lo hago después, el ordenador se queda leyendo pero no hace nada más. El proceso se abre en el Task Manager pero se queda ahí y es imposible cerrarlo.

He visto que es un error muy común y que algunos lo han podido solucionar, pero no me ha servido hasta ahora ninguna solución.

Tengo Windows 7, durante el proyecto uso Console Application y en las propiedades del proyecto ya he desactivado la casilla "Enable the Visual Studio hosting process".

Gracias a todos de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Visual CSharp .NET
- Código fuente de Visual CSharp .NET
- Chat de Visual CSharp .NET
información
Códigos de Visual CSharp .NET
- Juego de Naves en C SHARP NET
- Copiador de archivos
- Tetris

[Solucionado] The process cannot access the file.

Publicado por RatB (2 intervenciones) el 15/12/2015 11:55:28
Era el antivirus (Avast). Una vez lo desactivé todo se solucionó.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar