Windows Vista - Ayuda con Interp

   
Vista:

Ayuda con Interp

Publicado por Hector Franco hectito982@hotmail.com (1 intervención) el 25/11/2012 15:17:15
Hola como estan, estoy haciendo un programa en un lenguaje basico de programacion llamado interp, es para una tarea de programacion en la universidad, el programa debe leer distintos datos de "N" cantidad de almunos y al final procesarlos de una manera determinada. bien ya hice todo pero en los procesos me falta uno, tengo que calcular cual fue la maxima nota ingresada en cada materia y no consigo la forma de hacerlo, necesito ayuda, les dejo mi pseudocodigo, ya esta probado todo funciona bien, pero me falta eso, ese proceso y no se como hacerlo

inicio
borrar pantalla
imprimir "Programa que permite leer N tarjetas de datos A,B,C,D"
imprimir " A=Numero de cedula de identidad del alumno"
imprimir " B=Nota de matematicas"
imprimir " C=Nota de fisica"
imprimir " D=Nota de programacion"
imprimir " "
imprimir "Hallar:"
imprimir " *Nota promedio de cada materia"
imprimir " *Numero de alumnos aprobados en cada materia"
imprimir " *Numero de alumnos aplazados en cada materia"
imprimir " *Numero de alumnos que aprobaron todas las materias"
imprimir " *Numero de alumnos que aprobaron dos materias"
imprimir " *Nota maxima en cada materia"
imprimir " "
declarar variable entera tarjeta
declarar variable entera cedula
declarar variable flotante mate
declarar variable flotante fisi
declarar variable flotante prog
declarar variable flotante matematicap
declarar variable flotante fisicap
declarar variable flotante programacionp
declarar variable entera apromat
declarar variable entera repromat
declarar variable entera aprofi
declarar variable entera reprofi
declarar variable entera reproprog
declarar variable entera aproprog
declarar variable entera aprotodas
declarar variable entera aprouna
declarar variable entera aprodos
declarar variable flotante matepro
declarar variable flotante fisipro
declarar variable flotante progpro
imprimir "Por favor ingrese el numero de tarjetas que se desean procesar:"
leer tarjeta
para A de 1 hasta tarjeta hacer
imprimir "A: Por favor ingrese el numero de cedula de identidad del alumno", A
leer cedula
imprimir "B: Por favor ingrese la nota de matematicas del alumno", A
leer mate
matematicap = matematicap+mate
si mate < 10, entonces
repromat = repromat+1
sino
apromat = apromat+1
fin si
imprimir "C: Por favor ingrese la nota de física del alumno", A
leer fisi
fisicap = fisicap+fisi
si fisi < 10, entonces
reprofi = reprofi+1
sino
aprofi = aprofi+1
fin si
imprimir "D: Por favor ingrese la nota de programacion del alumno", A
leer prog
programacionp = programacionp+prog
si prog < 10, entonces
reproprog = reproprog+1
sino
aproprog = aproprog+1
fin si
si (mate>=10) y (fisi>=10) y (prog>=10), entonces
aprotodas = aprotodas+1
fin si
si (mate>=10 y fisi<10 y prog<10) o (mate<10 y fisi>=10 y prog<10) o (mate<10 y fisi<10 y prog>=10), entonces
aprouna = aprouna+1
fin si
si (mate>=10 y fisi>=10 y prog<10) o (mate<10 y fisi>=10 y prog>=10) o (mate>=10 y fisi<10 y prog>=10), entonces
aprodos = aprodos+1
fin si
fin para
matepro = matematicap/tarjeta
fisipro = fisicap/tarjeta
progpro = programacionp/tarjeta
imprimir " "
imprimir "La nota promedio de matematicas es:", matepro
imprimir "La nota promedio de fisica es:", fisipro
imprimir "La nota promedio de programacion es:", progpro
imprimir " "
imprimir "En matematica hay un total de alumnos aprobados de:", apromat
imprimir "En fisica hay un total de alumnos aprobados de:", aprofi
imprimir "En programacion hay un total de alumnos aprobados de:", aproprog
imprimir " "
imprimir "En matematica hay un total de alumnos reprobados de:", repromat
imprimir "En fisica hay un total de alumnos reprobados de:", reprofi
imprimir "En programacion hay un total de alumnos reprobados de:", reproprog
imprimir " "
imprimir "En total,",aprotodas," alumnos aprobaron todas las materias"
imprimir "En total hay",aprouna," alumnos que aprobaron solo una materia"
imprimir "En total hay",aprodos," alumnos que aprobaron solo dos materias"
fin
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder