Access - Checkbox marcado...con un cuadrado negro

 
Vista:
Imágen de perfil de Cm
Val: 106
Bronce
Ha disminuido 1 puesto en Access (en relación al último mes)
Gráfica de Access

Checkbox marcado...con un cuadrado negro

Publicado por Cm (68 intervenciones) el 02/08/2018 19:50:44
En un formulario de una aplicación de Access tengo un checkbox que debe de estar "unchecked" al principio, es decir en blanco. La idea es conseguir que ese objeto sólo tenga dos estados posibles:

Unchecked :
Checkbox3

Y checked:
Checkbox2

Sin embargo, al abrir el formulario el objeto aparece así:

Checkbox1

Pese a añadir una línea de VBA en el Subprocedimiento de Open_form

1
Objeto.Checked = False

Sigue pasando lo mismo, ¿Qué pasa aquí y cómo se podría resolver?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de jorge
Val: 1.031
Oro
Ha mantenido su posición en Access (en relación al último mes)
Gráfica de Access

Checkbox marcado...con un cuadrado negro

Publicado por jorge (293 intervenciones) el 03/08/2018 17:54:30
hola pregunta ese campo pertenece a una table saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Naren
Val: 128
Bronce
Ha mantenido su posición en Access (en relación al último mes)
Gráfica de Access

Checkbox marcado...con un cuadrado negro

Publicado por Naren (33 intervenciones) el 09/08/2018 18:05:26
cuando el check tiene fondo blanco es que tiene el valor FALSE, pero cuando aparece el cuadrito negro es que tiene asignado el valor NULL, o sea que no tiene un valor asignado
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Imágen de perfil de Cm
Val: 106
Bronce
Ha disminuido 1 puesto en Access (en relación al último mes)
Gráfica de Access

Checkbox marcado...con un cuadrado negro

Publicado por Cm (68 intervenciones) el 09/08/2018 18:07:54
Exacto. Eso era. Todo solucionado.

El problema era que se creaba basándose en una tabla y en un campo cuyo valor predeterminado era Null
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar