Algoritmia - ayuda algortimo que calcule los kilovatios consumidos según la zona donde vive

   
Vista:

ayuda algortimo que calcule los kilovatios consumidos según la zona donde vive

Publicado por Daniel (2 intervenciones) el 28/10/2017 20:50:47
Algoritmo que calcule los kilovatios consumidos según la zona donde vive. Si la zona es rural, el costo del kilovatio es de 32. Si la zona es urbana el costo del kilovatio es de 43.25, y si la zona es comercial es de 55. Visualizar; apellido y cédula del cliente, zona donde vive, y tomar en cuenta el iva (12%).

Algoritmo que calcule la ecuación de segundo grado ( resolvente), tomando en cuenta que la raíz no puede dar negativa y el denominador no puede dar 0.

Algoritmo que calcule el monto a cancelar por concepto de una llamada telefónica, si la llamada es local, el costo es de 20, si la llamada es a celular es de 35, si la llamada es nacional 72, y si es internacional 95. Visualizar; cédula del cliente, tipo de llamada, monto a cancelar, y cantidad de minutos.

Algoritmo que calcule el sueldo quincenal de un empleado ( apellido y cédula ), donde el costo de la hora diurna es de 745, la vespertina es de 780, y la nocturna 932.

-Si el empleado trabaja menos de 45 horas tendrá un descuento del 0.1% por seguro de vida.
-Si el empleado trabaja entre 40 y 80 horas, tendrá un descuento del 0.15% por seguro de vida
-Si el empleado trabaja mas de 80 horas, tendrá un descuento del 17% por seguro de vida. Visualizar; datos del empleado, horas trabajadas por turno, horas totales, sueldo quincenal sin descuento, sueldo quincenal con descuento.
-EL DESCUENTO ES MENSUAL.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

ayuda algortimo que calcule los kilovatios consumidos según la zona donde vive

Publicado por dario alderaan@ec-red.com (18 intervenciones) el 29/10/2017 06:27:57
Ejercicio Nro 1 en Python3

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
RURAL = 32
URBANO = 43.25
COMERCIAL = 55
IVA = 1.12
st = total = 0
 
while True:
  kv = int(input('Kilovation consumidos [0 para terminar]:'))
  if kv == 0:
    break
  else:
    apellido = input('Apellido del cliente:')
    cedula = input('Cedula del cliente:')
    zona = input('Zona donde vive [rural, urbano, comercial]:')
    if zona == 'rural':
      st = kv * RURAL
      total = st * IVA
      print('Apellido: %s' %apellido)
      print('Cedula: %s' %cedula)
      print('Zona: %s' %zona)
      print('Total a pagar: %.2f' %total)
    elif zona == 'urbano':
      st = kv * URBANO
      total = st * IVA
      print('Apellido: %s' %apellido)
      print('Cedula: %s' %cedula)
      print('Zona: %s' %zona)
      print('Total a pagar: %.2f' %total)
    else:
      st = kv * COMERCIAL
      total = st * IVA
      print('Apellido: %s' %apellido)
      print('Cedula: %s' %cedula)
      print('Zona: %s' %zona)
      print('Total a pagar: %.2f' %total)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

ayuda algortimo que calcule los kilovatios consumidos según la zona donde vive

Publicado por Daniel (2 intervenciones) el 29/10/2017 15:55:21
Hola! Gracias por la respuesta.

He estado haciendo ese algoritmo en Pseint y no me lanza alguna respuesta.

si conoces el error podrías decírmelo? Gracias!

Aquí tengo lo que he hecho;

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
Escribir " coloque su apellido y cedula "
	Leer a,b
	Escribir " kilovatios consumidos "
	Leer c
	Escribir "zona donde vive ( rural, comercial, urbana ) "
	Leer d
 
	rural = d
	urbano = d
	comercial = d
 
	si d==rural entonces
		costo<- d*32
		iva<- costo*0.12
		total<- costo+iva
 
 
	FinSi
 
 
	si d==urbano entonces
		costo<- d*43.25
		iva<- costo*0.12
		total<- costo+iva
 
	FinSi
 
	si d==comercial entonces
		costo<- d*55
		iva<- costo*0.12
		total<- costo+iva
 
	FinSi
 
	Escribir " APELLIDO ", a
	Escribir " CEDULA ", b
	Escribir " KILOVATIOS CONSUMIDOS ", c
	Escribir " SUB-TOTAL ", costo
	Escribir " IVA ", iva
	Escribir " TOTAL ", total
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

ayuda algortimo que calcule los kilovatios consumidos según la zona donde vive

Publicado por dario alderaan@ec-red.com (18 intervenciones) el 30/10/2017 04:21:40
Hola, no conozco mucho de Pseint. Sorry.
Salu2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar