Algoritmia - ejercicio de ciclos ayuda porfa

 
Vista:
Imágen de perfil de Jorge
Val: 5
Ha disminuido su posición en 5 puestos en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

ejercicio de ciclos ayuda porfa

Publicado por Jorge (3 intervenciones) el 11/09/2018 22:35:26
1) Una persona debe realizar un muestreo con 50 personas para determinar el promedio de peso de los
niños, jóvenes, adultos y viejos que existen en su zona habitacional. Se determinan las categorías con
base en la sig, tabla:

CATEGORÍA EDAD
Niños 0 - 12
Jóvenes 13 - 29
Adultos 30 - 59
Viejos 60 en adelante
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 110
Oro
Ha aumentado 1 puesto en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

ejercicio de ciclos ayuda porfa

Publicado por dario (47 intervenciones) el 12/09/2018 05:49:01
Te dejo este pseudo a ver si te sirve.
Salu2.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
Algoritmo promedioPesos
	sumaNinos = 0
	sumaJoven = 0
	sumaAdulto = 0
	sumaViejo = 0
	pesoNinos = 0
	pesoJoven = 0
	pesoAdulto = 0
	pesoViejo = 0
 
	Para i<-1 Hasta 5 Hacer
		Escribir "Ingrese edad: "
		leer edad
		Escribir "Ingrese peso: "
		leer peso
		si edad >= 0 y edad <= 12 Entonces
			sumaNinos = sumaNinos + 1
			pesoNinos = pesoNinos + peso
		SiNo
			si edad >= 13 y edad <= 29 Entonces
				sumaJoven = sumaJoven + 1
				pesoJoven = pesoJoven + peso
			SiNo
				si edad >= 30 y edad <= 59 Entonces
					sumaAdulto = sumaAdulto + 1
					pesoAdulto = pesoAdulto + peso
				SiNo
					sumaViejo = sumaViejo + 1
					pesoViejo = pesoViejo + peso
				FinSi
			FinSi
		FinSi
	FinPara
 
	Escribir "Promedio peso ninos ",pesoNinos/sumaNinos
	Escribir "Promedio peso jovenes ",pesoJoven/sumaJoven
	Escribir "Promedio peso adultos ",pesoAdulto/sumaAdulto
	Escribir "Promedio peso viejos ",pesoViejo/sumaViejo
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar