Algoritmia - ejercicios de algoritmo

 
Vista:

ejercicios de algoritmo

Publicado por Melany Ruiz (4 intervenciones) el 17/07/2019 20:25:59
1. elabore un algoritmo que permita determinar de 3 números ingresados, cual es el mayor, el intermedio y el menor
2. Elaborar un algoritmo que permita determinar si una persona es mayor de edad o no a partir del ingreso de la edad, se presentar como resultado el mensaje respectivo
3. Realice un algoritmo que permita calificar una nota, considerando que si la nota es menor a 39 es reprobado, entre 40 y 69 suspenso, mayor e igual a 70 aprobado
4. Realice un algoritmo para calcular el valor a pagar por una factura, en donde el consumo sea mayor a $100 tendrá un descuento del 2%
5. Se requiere un algoritmo que permita calcular el valor a pagar en una inscripción de membresía de un CLuB, para esto se establece la siguiente forma de pago, si el usuario es de género femenino se le aplicara un descuento del 5%, si el usuario es masculino y mayor a 40 años tendrá un descuento de 2%, considerar para el ingreso el nombre del usuario, el género y la edad, además el valor correspondiente de la inscripción es de $200 y se aplican los impuesto de IVA

6. Elaborar un algoritmo que a partir de ingreso del nombre del usuario y el género, presente un mensaje según la siguiente tabla
Genero Mensaje
Masculino Saludos <<NOMBRE>>
Femenino Buenos días <<NOMBRE>>

7. Un comerciante requiere calcular el valor a pagar por sus clientes, considerando que se conoce el valor a pagar y se debe de calcular el 3% de descuento de compras mayores a $2000
8. Se ingresa la edad y el género de un usuario, se requiere un algoritmo que permita presentar un mensaje considerando la siguiente combinación de valores según las variables ingresadas:
GENERO
MASCULINO FEMENINO EDAD MENSAJE
X >18 YA ERES UN SEÑOR
X <18 AUN ERES UN HIJITO DE MAMÁ
X >18 YA ERES UN ADULTO
X <18 AUN ERES UNA HIJITA DE MAMÁ

Ejemplo

Según la fila numero 2: si es MASCULINO Y MENOR A 18 AÑOS se presenta el mensaje “AUN ERES UN HIJITO DE MAMÁ”

9. Elabore un algoritmo, en donde se realizaran 3 preguntas, que serán ingresadas las respuestas:
• PREGUNTA 1: Indique su género (Masculino/femenino)?
• PREGUNTA 2: Indique su edad?
• PREGUNTA 3: Indique si le gusta desvelarse por la madrugada(Si/No)?
Según las respuestas dadas por el usuario, se debe de presentar el mensaje correspodiente según la tabla a continuación:
PREGUNTA1 PREGUNTA2 PEGUNTA3
MENSAJE MASCULINO FEMENINO EDAD SI NO
Eres un Maestro!! X >18 X
Eres una Maestra!! X >18 X
Eres un hijito de Mamá X <18 X
Eres una hijita de Mamá X <18 X
Eres una criatura de la noche X X >18 X
Cuídate mucho X X <18 X





alguien me ayuda con estos ejercicios me estan haciendo doler la cabeza la verdad no entiendo nada nada el profesor que me da estas clases no enseña nada
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 33
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

ejercicios de algoritmo

Publicado por virleskia (14 intervenciones) el 18/07/2019 04:29:17
Algoritmo Ejercicio 2
1
2
3
4
5
6
7
8
9
dim edad como entero
Imprimir "INGRESE EDAD DE LA PERSONA"
leer edad
si edad >= 18 entonces
imprimir "LA PERSONA ES MAYOR DE EDAD"
SiNo
imprimir "LA PERSONA ES MENOR DE EDAD"
finSi
finAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

ejercicios de algoritmo

Publicado por Melany Ruiz (4 intervenciones) el 18/07/2019 08:55:27
Muchas gracias de verdad me sirvio de mucho
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 83
Plata
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

ejercicios de algoritmo

Publicado por dario (38 intervenciones) el 18/07/2019 06:05:19
Ejercicio # 1

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Algoritmo mayorMenorIntermedio
	may = 0
	men = 0
	int = 0
 
	Imprimir "Digite 3 numero: "
	Leer a,b,c
 
	si a > b y a > c Entonces
		may = a
	SiNo
		si b > a y b > c Entonces
			may = b
		SiNo
			may = c
		FinSi
	FinSi
 
	si a < b y a < c Entonces
		men = a
	SiNo
		si b < a y b < c Entonces
			men = b
		SiNo
			men = c
		FinSi
	FinSi
 
	medio = a + b + c - men - may
 
	Imprimir "Mayor = ",may
	Imprimir "Menor = ",men
	Imprimir "Intermedio = ",medio
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

ejercicios de algoritmo

Publicado por Melany Ruiz (4 intervenciones) el 18/07/2019 08:56:30
Muchas gracias fue de gran ayuda
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 83
Plata
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

ejercicios de algoritmo

Publicado por dario (38 intervenciones) el 18/07/2019 06:24:58
Ejercicio # 3

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Algoritmo notas
	Imprimir "Digite una nota (entre 0-100): "
	Leer nota
 
	si nota <= 39 Entonces
		Imprimir "Reprobado"
	SiNo
		si nota >= 40 y nota <= 69 Entonces
			Imprimir "Suspenso"
		SiNo
			Imprimir "Aprobado"
		FinSi
	FinSi
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

ejercicios de algoritmo

Publicado por Melany Ruiz (4 intervenciones) el 18/07/2019 08:57:15
Muchas gracias fue de gran ayuda
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar