Algoritmia - Promedio Positivo y Negativo

 
Vista:
sin imagen de perfil
Val: 1
Ha disminuido su posición en 40 puestos en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

Promedio Positivo y Negativo

Publicado por Darshan (1 intervención) el 03/10/2019 02:22:14
Elaborar un algoritmo para calcular de una lista de N números el promedio de los números positivos y el promedio de los numero negativos.

Si alguien me puede ayudar con este ejercicio, se lo agradecería mucho.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 171
Oro
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

Promedio Positivo y Negativo

Publicado por Luis Horacio (63 intervenciones) el 03/10/2019 22:31:37
Inicio
Leer N
PromedioPositivos = 0
PromedioNegativos = 0
AcumuladorPositivos = 0
AcumuladorNegativos = 0

Para i = 1 hasta N
Imprimir "Ingrese numero"
Leer Numero

Si Numero > 0
AcumuladorPositivos = AcumuladorPositivos + Numero
FinSi

Si Numero < 0
AcumuladorNegativos = AcumuladorNegativos + 1
FinSi

FinPara

PromedioPositivos = AcumuladorPositivos / N
PromedioNegativos = AcumuladorNegativos / N

Imprimir PromedioPositivos
Imprimir PromedioNegativos
Fin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar