Algoritmia - algoritmo para Ingresar un numero de 5 cifras y mostrar un número formado por sus extremos

 
Vista:
sin imagen de perfil
Val: 2
Ha disminuido su posición en 2 puestos en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

algoritmo para Ingresar un numero de 5 cifras y mostrar un número formado por sus extremos

Publicado por MoSes (1 intervención) el 05/05/2020 18:38:15
Numero = 12345 Ingresar un numero de 5 cifras y mostrar lo siguiente:

a. Un nuevo número formado por sus extremos: 15
b. Un nuevo número formado por sus extremos pero invertido: 51
c. La suma total de los dígitos de la cifra: 15
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 172
Oro
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

algoritmo para Ingresar un numero de 5 cifras y mostrar un número formado por sus extremos

Publicado por Luis Horacio (63 intervenciones) el 06/05/2020 00:41:23
Buenas tardes, mira si te funciona asi:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Algoritmo numero
	definir num, primero, res, c, suma, ultimo Como Entero
	num = 0
	primero = 0
	c = 0
	suma = 0
	ultimo = 0
 
	leer num
 
	res = num - num mod 10000
	primero = res / 10000
 
	ultimo = num mod 10
 
	c = 10000
	Mientras c > 1 Hacer
		res = num - num mod c
		res = res / c
 
		suma = suma + res
 
		num = num - res * c
 
		c = c / 10
 
	FinMientras
 
	suma = suma + ultimo
 
	Escribir "Numero formado por sus extremos: ", primero, ultimo
	Escribir "Numero formado por sus extremos invertido: ", ultimo, primero
	Escribir "Suma total de los dígitos de la cifra:", suma
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Rodrigo
Val: 80
Plata
Ha aumentado 1 puesto en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

algoritmo para Ingresar un numero de 5 cifras y mostrar un número formado por sus extremos

Publicado por Rodrigo (24 intervenciones) el 06/05/2020 14:21:00
El ciclo para calcular la suma de los digitos parece mas facil hacerlo de derecha a izquierda que como se ofrece en el programa anterior

Algo asi como:

1
2
3
4
suma = 0
while numero > 0
  suma = suma + numero % 10
  numero = numero / 10

Asi hecho, se elimina el uso de la variable c, asignarla y actualizarla y la variable res para calcular el digito actual.
En el codigo de arriba el digito actual es siempre el ultimo de la derecha y se va diviendo por 10 para eliminarlo en cada iteracion.
Se obtiene y suma directamente.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 143
Oro
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

algoritmo para Ingresar un numero de 5 cifras y mostrar un número formado por sus extremos

Publicado por dario (62 intervenciones) el 07/05/2020 15:11:06
Otro pseudocodigo mas simple.
Salu2.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Algoritmo numero
	s  = 0 //acumulador de sumas
	Imprimir "Ingrese un numero de 5 digitos: "
	leer num
 
	n1 = num % 10
	n2 = trunc(num / 10000)
	x = num
 
	Imprimir n2,n1
	Imprimir n1,n2
 
	Mientras num != 0 Hacer
		x = num % 10
		s = s + x
		num = trunc(num / 10)
	FinMientras
 
	Imprimir "La suma de los digitos es ",s
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar