Algoritmia - Ya intente realizar el algoritmo pero no puede por eso pido que por favor me ayuden Gracias

 
Vista:

Ya intente realizar el algoritmo pero no puede por eso pido que por favor me ayuden Gracias

Publicado por Leidy (1 intervención) el 20/06/2020 18:09:42
En una empresa hay 5 empleados; usted, debe realizar un programa que lea el código de un trabajador, su nombre, el número de horas trabajadas y el valor de la hora y calcule su salario total bruto. Calcule el salario neto sabiendo que, si el salario bruto es menor a $1.000.000, hay un descuento de 10%, para salarios entre $1.000001 y $1.800.000, el descuento es de 15%, pare salarios entre $1.800.001 y $4.000.000 el descuento es de 25% y para salarios mayores a $4.000.000 el descuento es de 30%. Entregue el Valor Neto a pagar por los subsidios entregados por la empresa y el total descontado a los empleados.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 176
Oro
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

Ya intente realizar el algoritmo pero no puede por eso pido que por favor me ayuden Gracias

Publicado por Luis Horacio (63 intervenciones) el 20/06/2020 22:54:06
Buenas tardes, este sería el código

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
Proceso Salario
	Definir c, codigo, horas, valorhora,salbruto, descto, salneto como entero;
	Definir nombre como cadena;
 
	c <- 0;
	horas <- 0;
	codigo <- 0;
	nombre <- "";
	valorhora <- 0;
	salbruto <- 0;
	descto <- 0;
	salneto <- 0;
 
	Para c <- 1 hasta 2 con paso 1 hacer
		Escribir "Informacion Empleado ", c;
 
		Escribir "Digite el codigo";
		Leer codigo;
 
		Escribir "Digite el Nombre";
		Leer nombre;
 
		Escribir "Digite horas trabajadas";
		Leer horas;
 
		Escribir "Digite el valor de la hora";
		Leer valorhora;
 
		salbruto <- valorhora * horas;
 
		Si salbruto <= 1000000 Entonces
			descto <- salbruto * 0.10;
		SiNo
			Si salbruto > 1000000 y salbruto <= 1800000 Entonces
				descto <- salbruto * 0.15;
			SiNo
				Si salbruto > 1800000 y salbruto <= 4000000 Entonces
					descto <- salbruto * 0.25;
				SiNo
					descto <- salbruto * 0.30;
				FinSi
			FinSi
		FinSi
 
		salneto <- salbruto - descto;
 
		Escribir "Salario bruto: ", salbruto;
		Escribir "Total Descontado: ", descto;
		Escribir "Salario Neto: ", salneto;
	FinPara
 
FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar