Algoritmia - Ayuda con un algoritmo para encontrar el el máximo y el mínimo número dentro de una lista

 
Vista:
Imágen de perfil de Marcela
Val: 11
Ha mantenido su posición en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

Ayuda con un algoritmo para encontrar el el máximo y el mínimo número dentro de una lista

Publicado por Marcela (5 intervenciones) el 16/07/2020 03:59:16
Necesito escribir un algoritmo que encuentre el máximo y el mínimo número dentro de una lista de números enteros (desordenados). Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Ayuda con un algoritmo para encontrar el el máximo y el mínimo número dentro de una lista

Publicado por Maximo y Mínimo (11 intervenciones) el 12/09/2020 06:01:44
Algoritmo Maximo_y_Minimo_en_un_Arreglo_de_n_Elementos

Definir valores, mayor, menor, n Como Entero

Escribir "La cantidad de números del arreglo "
leer n

Dimension valores[n]

Para i <- 1 Hasta 4 Con Paso 1
valores[i] = azar(20)
Escribir "Los valores para la posición : [" , i , "] son : " valores[i]
FinPara

mayor <- 0
menor <- valores[1]

Para i <- 1 Hasta n Con Paso 1
Si ( valores[i] > mayor )
mayor <- valores[i]
FinSi
FinPara

Para i <- 2 Hasta n Con Paso 1 Hacer
Si ( menor > valores[i] )
menor <- valores[i]
FinSi
FinPara

Escribir "El número máximo del arreglo es : " mayor
Escribir "El número minimo del arreglo es : " menor

FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar