Algoritmia - Algoritmica Año Bisiesto Por Favor

 
Vista:
sin imagen de perfil
Val: 4
Ha aumentado su posición en 36 puestos en Algoritmia (en relación al último mes)
Gráfica de Algoritmia

Algoritmica Año Bisiesto Por Favor

Publicado por Osvaldo (4 intervenciones) el 29/08/2020 20:20:29
Hacer un proceso que permita ingresar una serie de números de cuatro digitos que representan
años. Imprimir todos aquellos que representan años bisiestos (son bisiestos
los múltiplos de 4, excepto los múltiplos de 100 que no lo son de 400)


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
ENTORNO
 
NUM es numerico
 
PROCESO_INICIAL:
 
ingresar "Ingrese  Numero de cuatro digitos"
 
retorno
 
PROCESO_PRINCIPAL:
Si  Num <> 1000 and Num <> 9999
   imprimir "Error, el número debe ser de 4 cifras"
sino
       si Num /4 = 0 and Num / 100 <> 100 and Num / 400 = 0
     imprimir "Año Bisiesto"
 fin_si
fin_si
 
retorno
 
 
PROCESO_FINAL
 
imprimir "** FIN DEL PROCESO**"
 
retorno
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder