Bases de Datos Multidimensionales - Macros en excel

 
Vista:

Macros en excel

Publicado por Daniel Cabelardis (1 intervención) el 15/07/2002 22:39:12
Hola !!!!

Mi duda es la siguiente: Estoy utilizando la condicion "if" en una celda, pero quiero que en una de las respuestas "logica" o "verdadera" utilizar una macro pero no se como escribirla en la celda.
Ejemplo.
if(A1>A2, "Mayor", Macro X)

Ahora, yo se que si escribo Macro X me saldra un error, como escribirla???

GRACIAS!!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Macros en excel

Publicado por Oscar (1 intervención) el 17/05/2008 16:51:40
Mi solución es la siguiente.
Debes crear una macro con visual basic así


Public Ejecutar As Boolean

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Hoja1.Cells(13, 6) = "si" And Ejecutar = True Then
MsgBox "Hola"
Ejecutar = False
End If
If Hoja1.Cells(13, 6) = "no" Then
Ejecutar = True
End If
End Sub


Hice una pequeña condicional si en la celda 13,6 columna f fila 13 donde si dos numeros son iguales le asigna si y de lo contrario le asigna no

=SI(D13=E13;"si";"no")

Ya la ejecuta y me dio. Ok Esppero te sirva mucho sino comunicate conmigo a cali colombia 3174033123 profe Oscar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Macros en excel

Publicado por juv montoya (2 intervenciones) el 17/11/2010 22:37:22
buenas tardes


quien me puede cola borar es q necesito hacer una base de datos de 6 registros

con un botor guardar y otro boton salir


gracias para los q me puedan colaborar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Macros en excel

Publicado por juv montoya (2 intervenciones) el 17/11/2010 22:37:24
buenas tardes


quien me puede cola borar es q necesito hacer una base de datos de 6 registros

con un botor guardar y otro boton salir


gracias para los q me puedan colaborar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad