Crystal Report - problemas con decimales

 
Vista:

problemas con decimales

Publicado por larios75 (2 intervenciones) el 13/12/2005 10:37:06
Me ocurre algo muy raro, si creo un listado con algun campo numerico con decimales, cuando le doy a vista previa desde el crystal report, me muestra bien los datos, pero si tiro el listado desde Visual basic los decimales me salen todos a 0(por ejemplo, si debe mostrar 2,65 me sale en el listado 2,00)
Si alguien sabe como solucionar esto lo agradecería

Saludos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problemas con decimales

Publicado por Carlos (2 intervenciones) el 13/12/2005 14:23:27
Por favor, este mismo problema me pasa con el Crystal Report, accediendo de varias maneras (odbc, sql Server). Si tienes alguna pista
de como solucionarlo, enviame un correo: carlos9331@hotmail.com, ya que he probado de todo y no lo consigo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problemas con decimales

Publicado por Shitor (1 intervención) el 27/01/2006 12:36:15
buenas,

Yo le paso los datos desde una BD access introducidos por VB6, y me pasaba lo mismo, lo que hice fue declarar el campo "tamaño del campo" de la base de datos access como "Doble", tambien asegurate de que en el report tienes bien puesto en el formato del campo los 2 decimales.

Saludos.

Pd: si sabeis como apaisar un report os agradeceria que me enviaseis un correo con la respuesta
Gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar